I set up a local MySQL server, currently with no databases. I'm trying to create a new server instance profile in MySQL Workbench to manage the server, and during the Create New Server Instance Profile wizard, it gets to the Windows Management section and tells me that No MySQL service found.

I went into Task Manager and found the process mysqld.exe to be running, under the user name of NETWORK SERVICE. Then I went into the Services tab and found that MySQLServerName (I custom named the Windows service) is also there, and status is running.

I ran cports and looked at what ports mysqld.exe is using, and ran a telnet command on that port. It's reporting that the port is being listened in on. I then ran the MySQL Command Line Client to be sure, and after \r it gives me a proper connection ID and a list of databases (NONE at this point).

But with all this, I can't make the wizard find a running service. I've Googled this and found no answers, so please, if someone would help shed some light on this issue that'd be great!

  • Did this ever resolve?`I have same problem, and very little solutions.
    – user25187
    Jun 20, 2013 at 12:56

2 Answers 2


I custom named the Windows service

This may seem a bit of an obvious question... but have you considered not doing that?

  • Yes, someone else suggested this to me and I uninstalled/reinstalled the server using the default name. That didn't work either :(
    – jayjyli
    Nov 20, 2012 at 8:30
  • Pity, I felt pretty good about that one. Please provide your version of workbench, version of MySQL, version of Windows and architecture (32/64 bit) and I'll see if I can find a way to replicate this. Nov 20, 2012 at 19:16
  • Workbench 5.2 CE, Windows 7 x64, MySQL 5.5. I also have an SSD to boot off of and an HDD to store misc. installations on. MySQL is installed on the boot drive, if any of that matters. Thanks for the help, lemme know how it goes!
    – jayjyli
    Nov 22, 2012 at 18:12
  • What are the full versions? Workbench 5.2.??, MySQL Server 64-bit version 5.5.??, and Windows 7 (Pro? Home Premium? Ultimate?) And, you did accept all default values on the installs this time around? Nov 22, 2012 at 21:11
  • MySQL Server 5.5.28, Workbench CE 5.2.44, Windows 7 Pro. Yes, all default options were selected this time, I just clicked through next for whatever screen during the installer, except for the part where it asks me to set a root/user password for the service.
    – jayjyli
    Nov 23, 2012 at 7:05

I had the same problem and solved it : I have installed mysql via WAMP

The process name of mysql is wampmysqld.

=> So i changed in the menu : Server -> Management access settings -> Windows Service Name It was written MySql and I changed it by wampmysqld and it worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.