0

SSMS Version 17.9.1

It looks like the intellisense may not be working? Shouldn't it auto complete Select etc? Also, it looks like the intellisense is from SSMS itself (doesn't work that great)

enter image description here

I've checked the Intellisense setting and it's there just fine, also put the cache size on unlimited

enter image description here

6
  • 2
    This question is about the third party SSMS extension SSMSBoost. SSMS support support for extensions is notoriously flaky. Many folks (myself included) have given up on them for this reason. Have you tried contacting support from the vendor? – AMtwo Jan 19 at 23:00
  • @LowlyDBA-JohnMcCall yeah I tried all that, didn't work, the post is also from 2011 and I tried recent posts too – sojim2 Jan 19 at 23:33
  • Try the newest 18.8 SSMS. At the very least, that'll also install Azure Data Studio which actually has somewhat reliable Intellisense (compared to SSMS). – LowlyDBA - John McCall Jan 20 at 0:18
  • @LowlyDBA-JohnMcCall installed but same behavior: i.imgur.com/2QIa6s6.gif (with SSMSboost and without) – sojim2 Jan 20 at 1:05
  • Trying out SQL Complete now, looks like the intellisense works on that – sojim2 Jan 20 at 1:49
0

Please, try to reset Intellisense Cache:

CTRL+SHFT+R

But Intellisense completes object names not sql statement like SELECT.

Not the answer you're looking for? Browse other questions tagged or ask your own question.