0

I am currently in the process of setting up a database in MySQL for an application where I will be running PowerBI to do analyses on the data in the database and in a further stage to design an application to upload/download data from this db.

I tried to install the 8.0.23.0 Community Edition through the MySQL Installer. I installed MySQL Server, Shell, Workbench and the ODBC Connector (I want to use Access as a front end) and the NET Connector (I want to import the data in PowerBI). Furthermore I choose to not have MySQL running as a Windows Service as it would keep running in the background. I am currently using my machine with limited hardware resources both as a host and a client. We don't have dedicated infrastructure yet and I am purely using my machine to test/develop.

What I would like to be able to do is the following: starting the server instance through MySQL Workbench when working on the project, open Microsoft Access and PowerBI to work on both the reports and the database. After finishing, I would stop the server instance again through MySQL Workbench.

My problem is the following: I am not succeeding in stopping/starting the instance from Workbench and I get the following error message:enter image description here

I succeed in stopping the server instance through CMD but when trying to start again I get the following messages:enter image description here

Does anyone know wha I am doing wrong? Did I not install enough packages to get it running or did I configure someting wrong?

Thanks in advance!

5
  • The datadir directory does not exist. I tried to manually add one through file explorer and the error disappeared in CMD. However, after opening in Workbench I was still not able to connect as it seemed offline. Therefore, it seemed like the server did not start. Furthermore, do you mean the MySQL account or my windows account? I did not any MySQL users as I am accessing with 'root'. My Windows Account is Administrator of this machine so I guess I have 'PERMIT ALL'?
    – SDR3078
    Commented Jan 27, 2021 at 13:32
  • The datadir directory does not exist. If so then server installation was performed wrongly. Remove it completely and reinstall.
    – Akina
    Commented Jan 27, 2021 at 13:43
  • Maybe also some good information to add: when I startup Workbench immediately after installing everything functions as should. It is solely after shutting down the database that the problems arise.
    – SDR3078
    Commented Jan 27, 2021 at 13:44
  • Tried to reinstall twice now, datadir does not show up for some reason...
    – SDR3078
    Commented Jan 27, 2021 at 13:44
  • look for an my.ini file, the service and all mysql start procidures should point to it usuqally it sis under `C:\ProgramData\MySQL\MySQL Server 8.0\Dat
    – nbk
    Commented Jan 27, 2021 at 19:09

2 Answers 2

0

This is bug in Workbench. We have bug report for that start/stop issue. This problem was caused by migration from python2.7 to python3 and only affect last WB release. We working on that and it is already partially fixed.

1
  • Is there a way to have a workaround in te meantime? As I said, starting and stopping from CMD is also not working.
    – SDR3078
    Commented Jan 28, 2021 at 9:59
0

I managed to get it working but not through workbench nor through CMD. I installed the server as a Windows service and wrote 2 batch files to start and stop the service.

Because of the difficulties and the limited resources on my own machine, I decided to go to an Azure SQL server, thank for the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.