0

I am trying to setup a MySQL InnoDB Cluster. I configured each node involved using dba.configureInstance(...). Everything was nominal until I ran var cluster = dba.createCluster('clusterNmae'). When I run this command I get this error:

ERROR: Unable to start Group Replication for instance 'my-mysql-cluster-1:3306'. 
Please check the MySQL server error log for more information.
Dba.createCluster: Group Replication failed to start: MySQL Error 2013 (HY000): my-mysql-cluster-1:3306: Lost connection to MySQL server during query (RuntimeError)

So I modified the max_allowed_packet to max_allowed_packet = 512M but I still get the same error.

Here is the complete error log for mysql:

2021-03-02T21:12:52.161487Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.23-0ubuntu0.20.04.1) starting as process 1410
2021-03-02T21:12:52.173719Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2021-03-02T21:12:52.542976Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2021-03-02T21:12:52.686661Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2021-03-02T21:12:52.688284Z 0 [System] [MY-013587] [Repl] Plugin group_replication reported: 'Plugin 'group_replication' is starting.'
2021-03-02T21:12:52.707092Z 0 [System] [MY-010229] [Server] Starting XA crash recovery...
2021-03-02T21:12:52.722770Z 0 [System] [MY-010232] [Server] XA crash recovery finished.
2021-03-02T21:12:52.778384Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2021-03-02T21:12:52.778578Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2021-03-02T21:12:52.802880Z 0 [Warning] [MY-010604] [Repl] Neither --relay-log nor --relay-log-index were used; so replication may break when this MySQL server acts as a slave and has his hostname changed!!>
2021-03-02T21:12:52.808702Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.23-0ubuntu0.20.04.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2021-03-02T21:12:52.815373Z 10 [System] [MY-010597] [Repl] 'CHANGE MASTER TO FOR CHANNEL 'group_replication_applier' executed'. Previous state master_host='<NULL>', master_port= 0, master_log_file='', maste>
2021-03-02T21:12:52.820635Z 2 [ERROR] [MY-011735] [Repl] Plugin group_replication reported: '[GCS] Unable to join the group: peers not configured. '
2021-03-02T21:12:52.820668Z 2 [ERROR] [MY-011639] [Repl] Plugin group_replication reported: 'Error on group communication engine start'
2021-03-02T21:12:52.820682Z 2 [ERROR] [MY-011735] [Repl] Plugin group_replication reported: '[GCS] The member is leaving a group without being on one.'

I'm running ubuntu 20.04 on all instances.

Why do I get this error(s) and what can I do to get over it? Thank you!

1
  • Do you have the hostname of this node with its network IP (not 127.0.0.1) in /etc/hosts? Jun 3 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.