0

After successfully building my project, I got this error when deploying it:

The project could not be deployed to the '\SQLEXPRESS' server because of the following connectivity problems :

A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running.

To verify or update the name of the target server, right-click on the project in Solution Explorer, select Project Properties, click on the Deployment tab, and then enter the name of the server.

Things I've checked/tried so far:

  • Changing the deployment server name (from localhost to my actual SQL Server name)
  • Making sure SQL Server Browser service is running (which is running in SSCM)
  • Registry SSrpListener value (should be 1 -- mine is 1)
  • Running both Visual Studio and SSCM as administrator

Versions:

  • Visual Studio Community 2019 (16.9.2)
  • SQL Server Data Tools (16.0.62103.10080)
  • SQL Server Analysis Services (15.0.19445.0)
  • SQL Server Configuration Manager (2019.0150.2000.05)
  • SQL Server Management Studio (15.0.18369.0 or v18.8)
  • SQL Server 2019 Express (15.0.2000.5)
  • Windows 10 (10.0.19042)

Based on the information I've provided above, I still could not deploy the project.

1 Answer 1

1

i'm not sure to have a good view of what you are doing...

But i can say that SASS service is not included with sql server express. You can only have the reletional database service .\SQLEXPRESS, not the analytics database that is SSAS.

https://docs.microsoft.com/en-us/analysis-services/analysis-services-features-supported-by-the-editions-of-sql-server-2016?view=asallproducts-allversions

Instead of Express edition, download devenloper edition. It's free for not production env and full of features like enterprise edition. So you can test everything. Don't use it in production.

During sql dev setup be sure to select SASS instance too: enter image description here

4
  • I tried using the developer edition but with no luck. I've tried changing the deployment name multiple times. These are the names I've tried: localhost, <computername>, <computername>\MSSQLSERVER, and <computername>\. The only thing I've noticed is that the error changes from "Ensure that 'SQL Browser' is running" to "Ensure that the server is running".
    – dbybanez
    Mar 23, 2021 at 13:54
  • what is your ssas instance name? are you able to connect to it with ssms? during setup have you chosen to installal sql services and ssas instance too?
    – MBuschi
    Mar 23, 2021 at 20:44
  • Which version of SSMS are you using? From the SQL Server 2019 Developer edition, it only says Install SQL Server Data Tools which I already did. When I open SSMS, it shows the Analysis Service under Object Explorer > Connect. But it won't let me connect. It gives me an error "Ensure that the server is running". I tried checking the SSCM, but it doesn't show the Analysis Service under SQL Server Services.
    – dbybanez
    Mar 25, 2021 at 15:52
  • Solved it. I'm so stupid. I missed the part where I need to install Analysis Service in the SQL Server installation wizard and then select the multidimensional mode. Everything is working fine now. Thanks for your help. And you are correct, this will only work in SQL Server Developer edition and not in Express edition. In Express edition, Analysis Service option is not available.
    – dbybanez
    Mar 25, 2021 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.