I am struggling since yesterday regarding the error, first my SSMS expired for some reason & i was not able to get it working. I was not abel to unstall all the soofware related to SQL Server & it shared components, I was removing it successfully & i was getting the same error after reinstalling MS Sql server 2008 r2 express & SSMS you trial version has expired.

At last i messed up everything by forcing MS SQL SERVER & its component when i removed it with CClearner as suggested in one of the article.

An now i am not able to install any version of MS SQL Server whether it be SQL Server 2008, MS SQL SERVER 2008 Express or MS SQL SERVER 2008 Re Express edition i get following message for all the version as show in image below\

enter image description here

I am not sure what to do either i reinstall windows 7 or try to search further for solution which i would prefer as i had several software installed on my system & it will take me day or so to install all software.

I would appreciate help regarding this

Log error reporter under file folder C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log


Overall summary:
  Final result:                  SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup.
  Exit code (Decimal):           -2068643839
  Exit facility code:            1203
  Exit error code:               1
  Exit message:                  Method not found: 'Void Microsoft.SqlServer.Configuration.MsiExtension.PackageInstallProperty.set_FailedPatchedFeatureList(System.Collections.Generic.List`1<System.String>)'.
  Start time:                    2012-11-18 16:32:54
  End time:                      2012-11-18 16:34:07
  Requested action:              Install
  Log with failure:              C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20121118_163146\Detail.txt
  Exception help link:           http%3a%2f%2fgo.microsoft.com%2ffwlink%3fLinkId%3d20476%26ProdName%3dMicrosoft%2bSQL%2bServer%26EvtSrc%3dsetup.rll%26EvtID%3d50000%26ProdVer%3d10.0.1600.22%26EvtType%3d0x6539C9E6%400x375DE77D

Machine Properties:
  Machine name:                  WEBD
  Machine processor count:       4
  OS version:                    Windows Vista
  OS service pack:               Service Pack 1
  OS region:                     United Kingdom
  OS language:                   English (United States)
  OS architecture:               x86
  Process architecture:          32 Bit
  OS clustered:                  No

Product features discovered:
  Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered 

Package properties:
  Description:                   SQL Server Database Services 2008
  SQLProductFamilyCode:          {628F8F38-600E-493D-9946-F4178F20A8A9}
  ProductName:                   SQL2008
  Type:                          RTM
  Version:                       10
  SPLevel:                       0
  Installation location:         c:\1ecd7ad03bd0c2d4ee57a72099f430\x86\setup\
  Installation edition:          EXPRESS

User Input Settings:
  ACTION:                        Install
  AGTSVCACCOUNT:                 <empty>
  AGTSVCPASSWORD:                *****
  AGTSVCSTARTUPTYPE:             Manual
  ASBACKUPDIR:                   Backup
  ASCOLLATION:                   Latin1_General_CI_AS
  ASCONFIGDIR:                   Config
  ASDATADIR:                     Data
  ASDOMAINGROUP:                 <empty>
  ASLOGDIR:                      Log
  ASPROVIDERMSOLAP:              1
  ASSVCACCOUNT:                  <empty>
  ASSVCPASSWORD:                 *****
  ASSVCSTARTUPTYPE:              Automatic
  ASSYSADMINACCOUNTS:            <empty>
  ASTEMPDIR:                     Temp
  ENABLERANU:                    False
  ERRORREPORTING:                False
  FILESTREAMLEVEL:               0
  FILESTREAMSHARENAME:           <empty>
  FTSVCACCOUNT:                  <empty>
  FTSVCPASSWORD:                 *****
  HELP:                          False
  INDICATEPROGRESS:              False
  INSTALLSHAREDDIR:              c:\Program Files\Microsoft SQL Server\
  INSTALLSHAREDWOWDIR:           C:\Program Files\Microsoft SQL Server\
  INSTALLSQLDATADIR:             <empty>
  INSTANCEDIR:                   C:\Program Files\Microsoft SQL Server\
  INSTANCEID:                    <empty>
  INSTANCENAME:                  <empty>
  ISSVCACCOUNT:                  NT AUTHORITY\NetworkService
  ISSVCPASSWORD:                 *****
  ISSVCSTARTUPTYPE:              Automatic
  NPENABLED:                     0
  PID:                           *****
  QUIET:                         False
  QUIETSIMPLE:                   False
  RSINSTALLMODE:                 FilesOnlyMode
  RSSVCACCOUNT:                  <empty>
  RSSVCPASSWORD:                 *****
  RSSVCSTARTUPTYPE:              Automatic
  SAPWD:                         *****
  SECURITYMODE:                  <empty>
  SQLBACKUPDIR:                  <empty>
  SQLCOLLATION:                  SQL_Latin1_General_CP1_CI_AS
  SQLSVCACCOUNT:                 <empty>
  SQLSVCPASSWORD:                *****
  SQLSVCSTARTUPTYPE:             Automatic
  SQLSYSADMINACCOUNTS:           <empty>
  SQLTEMPDBDIR:                  <empty>
  SQLTEMPDBLOGDIR:               <empty>
  SQLUSERDBDIR:                  <empty>
  SQLUSERDBLOGDIR:               <empty>
  SQMREPORTING:                  False
  TCPENABLED:                    0
  X86:                           False

  Configuration file:            C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20121118_163146\ConfigurationFile.ini

Detailed results:
  Feature:                       Database Engine Services
  Status:                        Failed: see logs for details
  MSI status:                    Passed
  Configuration status:          Passed

  Feature:                       SQL Client Connectivity SDK
  Status:                        Failed: see logs for details
  MSI status:                    Passed
  Configuration status:          Passed

  Feature:                       SQL Server Replication
  Status:                        Failed: see logs for details
  MSI status:                    Passed
  Configuration status:          Passed

Rules with failures:

Global rules:

Scenario specific rules:

Rules report file:               C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20121118_163146\SystemConfigurationCheck_Report.htm

Exception summary:
The following is an exception stack listing the exceptions in outermost to innermost order
Inner exceptions are being indented

Exception type: Microsoft.SqlServer.Setup.Chainer.Workflow.ActionExecutionException
        Method not found: 'Void Microsoft.SqlServer.Configuration.MsiExtension.PackageInstallProperty.set_FailedPatchedFeatureList(System.Collections.Generic.List`1<System.String>)'.
      DisableWatson = true

        Server stack trace:
        at Microsoft.SqlServer.Configuration.BootstrapExtension.ExecuteWorkflowAction.HandleActionException(Exception e, TextWriter logging)
        at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionEngine.NotifyOnUnhandledException(Exception e)
        at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionEngine.RunActionQueue()
        at Microsoft.SqlServer.Setup.Chainer.Workflow.Workflow.RunWorkflow(HandleInternalException exceptionHandler)
        at Microsoft.SqlServer.Configuration.BootstrapExtension.ExecuteWorkflowAction.ExecuteAction(String actionId)
        at Microsoft.SqlServer.Configuration.NestedWorkflow.ExecuteWorkflow(ServiceContainer context, String sequencesRootPath, ActionKey sequenceId)
        at Microsoft.SqlServer.Configuration.NestedWorkflow.ExecuteWorkflow(ServiceContainer context, String sequenceId)
        at Microsoft.SqlServer.Configuration.InstallWizardFramework.InstallWizardPageHost.<>c__DisplayClass2.<ExecuteAction>b__0()
        at Microsoft.SqlServer.Configuration.WizardFramework.BlockingWorker.ThreadCallBack(MethodInvoker method)
        at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
        at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
        at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

        Exception rethrown at [0]:
        at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
        at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
        at Microsoft.SqlServer.Configuration.WizardFramework.BlockingWorker.WorkerCallback.EndInvoke(IAsyncResult result)
        at Microsoft.SqlServer.Configuration.WizardFramework.BlockingWorker.PerformWork(MethodInvoker method)
        at Microsoft.SqlServer.Configuration.InstallWizardFramework.InstallWizardPageHost.ExecuteAction(String actionName)
        at Microsoft.SqlServer.Configuration.InstallWizardFramework.InstallWizardPageHost.PageLeft(PageChangeReason reason)
        at Microsoft.SqlServer.Configuration.WizardFramework.UIHost.set_SelectedPageIndex(Int32 value)
        at Microsoft.SqlServer.Configuration.WizardFramework.UIHost.GoNext()
        at Microsoft.SqlServer.Configuration.WizardFramework.NavigationButtons.nextButton_Click(Object sender, EventArgs e)
        at System.Windows.Forms.Control.OnClick(EventArgs e)
        at System.Windows.Forms.Button.OnClick(EventArgs e)
        at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
        at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
        at System.Windows.Forms.Control.WndProc(Message& m)
        at System.Windows.Forms.ButtonBase.WndProc(Message& m)
        at System.Windows.Forms.Button.WndProc(Message& m)
        at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
        at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
        at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    Inner exception type: System.MissingMethodException
                Method not found: 'Void Microsoft.SqlServer.Configuration.MsiExtension.PackageInstallProperty.set_FailedPatchedFeatureList(System.Collections.Generic.List`1<System.String>)'.
                at Microsoft.SqlServer.Configuration.SetupExtension.SetFeatureConfigStateAction.ExecuteAction(String actionId)
                at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
                at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.InvokeAction(WorkflowObject metabase, TextWriter statusStream)
                at Microsoft.SqlServer.Setup.Chainer.Workflow.PendingActions.InvokeActions(WorkflowObject metaDb, TextWriter loggingStream)

Related question which i had asked yesterday SQL Server 2008 R2 Management Studio : "Evaluation period has expired"

Configuration: Window 7 32 bit with 4GB RAM

  • I think you are still confused between SQL Server 2008 and SQL Server 2008 R2. They are NOT the same! Nov 19, 2012 at 15:19

3 Answers 3


Windows Vista Service Pack 1 is actually not supported by SQL Server 2008 R2. In addition to my multiple suggestions to really clean 2008 R2 off your system (again see instructions here and here), I strongly recommend you install Service Pack 2 before trying again. If you're going to completely reinstall your OS, you might consider Windows 7 which has a longer lifetime and will continue to support more modern versions of SQL Server.


Have you looked at: http://www.headcrash.us/blog/2010/11/sql-management-studio-express-install-fails-with-exception/

Issue: When installing SQL Server Management Studio on top of an existing SQL Server 2008 or SQL Server 2008 R2 installation, the setup program may fail with the following .NET Framework exception, even if the .NET Framework 3.5 and 4.0 is already installed on the target machine:

Resolution: Resolution

Delete the offending user.config file in the following directory:


Restart the installer and note that the deleted configuration file will be recreated with corrected settings for the System.Configuration assembly’s version number.

  • Microsoft_Corporation is missing all to gather under specific user i can see only Local, Locallow & Roaming folder under AppData folder
    – Learning
    Nov 19, 2012 at 6:21
  • have you looked for user.config in the whole computer and do you have full admin rights on the machine? Nov 19, 2012 at 6:44
  • It was under folder C:\Users\xxxx\AppData\Local\Microsoft_Corporation\LandingPage.exe_StrongName_ryspccglaxmt4nhllj5z3thycltsvyyx\ but this didnt solve the problem & it is not event creating any file in this flder i am getting same error as show in image above..
    – Learning
    Nov 19, 2012 at 7:34
  • It might be a hidden file, you can check your hidden file view settings by opening up any explorer window (my computer), hitting ALT to bring u the menu, tools, folder options, view, 'show hidden files', OK. If it is hidden, that'll let you see it. Didn't Aaron have you download SSMS 2012? Have you tried that? Nov 19, 2012 at 7:52
  • 4
    No, don't completely reinstall your OS. Just remove SQL Server completely (not using CCLeaner). As I commented in my other answer, I give instructions in this link which have helped countless other users. Nov 19, 2012 at 15:32

Unfortunately I had to reinstall my OS (windows 7) as nothing seemed to work for me, I tried almost every option i could find on web for two days. Finally i installed windows 7 Professional OEM, Updated it with latest updates from Microsoft including Service Packs. After this i had no issues installing MS SQL SERVER 2008 R2 Express edition (with Management Tools).

I think the culprit was CCleanersoftware which i used to fix registry & it also deleted some temp files which i could not get back, I restored my system to last working condition which didn't even fix the solution. Simply fixing one problem gave rise to another problem. I never had any issue with MS SQL SERVER Installation since i started using it in 1998.

I am sure CCleaner started trouble after i used clean option to clear temporary files which MS SQL SERVER could not find after i tried to reinstall it.

I learned my lesson hard way, Will never use any such software to fix issues.

  • So you reinstalled Windows Vista SP1, and then everything just magically worked? Nov 20, 2012 at 12:38
  • No, had to do a fresh installation of windows 7 OS & then i installed other software including Service Packs required for MS SQL Server 2008 R2 express.
    – Learning
    Nov 21, 2012 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.