2

When I try to execute an SSIS package with DTExec.exe with a batch file or in the command prompt it gives me error code 0xC0040019 Data Flow Task 1 (SSIS.Pipeline) data flow objects cannot be loaded. Check if Microsoft.Sqlserver.pipelinexml.dll is properly registered.

I tried storing the SSIS package in the server and in the file system but get the same error. The strange part is when I try to execute the package from DTExecUI.exe it runs without any problems. I tried generating the command line in DTExecUI.exe and using that in the batch file but I still get an error.

I did notice that my server is 64bit and DTExec.exe and DTExecUS.exe are both 32bit versions. I don't know if this is the problem but if so why would one work and the other fail?

3
  • is there a good cause, why you missing qeiting alsi the error message?
    – nbk
    Commented Apr 14, 2021 at 17:27
  • You likely have 32 and 64 bit variants of dtexec and quite possibly more than one version of it on your machine. From a command prompt where dtexec.exe If you would please click the edit button and post the entirety of your dtexec call and the full output from the screen. If you don't supply a /REP parameter to your call, please use /REP IEW so we can see any errors, warnings or information messages.
    – billinkc
    Commented Apr 15, 2021 at 0:54
  • Did you ever fix this? I'm experiencing the same issue now. Confirmed the same version of DTSWizard was used to create a package yet DTExecUI works, and DTExec doesn't Commented Oct 26, 2022 at 22:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.