0

I was having a problem after migrating my Database from 11.2.0.4 to 19c using dbua.

The migration process using dbua is smooth and successful except for migrating the TNS listener. I finally migrate the database without the listener and aims to create another listener after the migration.

I followed the instructions in "Net Configuration Assistant" to create a listener with the default port (1521). The listener is created successfully.

When I tried to start the newly created listener service, the following error is shown in the log,

Error listening on: (ADDRESS=(PROTOCOL=ipc))
TNS-01191: Failed to initialize the local OS authentication subsystem
 TNS-12557: TNS:protocol adapter not loadable
  TNS-12560: TNS:protocol adapter error
   TNS-00527: Protocol Adapter not loadable

I did some research about the error TNS-01191 and I had already updated the environment variables "PATH" with the new Oracle home bin directory.

May I know if anyone had installed Oracle 19c on Windows 7 and configured the TNS listener successfully?

FYI, the tnsnames.ora

# Generated by Oracle configuration tools.

ORACLR_CONNECTION_DATA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    )
    (CONNECT_DATA =
      (SID = CLRExtProc)
      (PRESENTATION = RO)
    )
  )

The listener.ora

# Generated by Oracle configuration tools.

SID_LIST_LISTENERFORSD =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = CLRExtProc)
      (ORACLE_HOME = <ORACLE_HOME_MASKING>)
      (PROGRAM = extproc)
      (ENVS = "EXTPROC_DLLS=ONLY:<ORACLE_HOME_MASKING>\bin\oraclr19.dll")
    )
    (SID_DESC =
      (SID_NAME = CLRExtProc)
      (ORACLE_HOME = <ORACLE_HOME_MASKING>)
      (PROGRAM = extproc)
      (ENVS = "EXTPROC_DLLS=ONLY:<ORACLE_HOME_MASKING>\bin\oraclr19.dll")
    )
  )

<LISTENER_NAME_MASKING> =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = <HOSTNAME_MASKING>)(PORT = 1521))
    )
  )
0

2 Answers 2

3

Windows 7 is not a supported operating system for Oracle 19c.

The documentation states that it is only supported for these versions of Windows:

Windows 8.1 x64 - Pro and Enterprise editions

Windows 10 x64 - Pro, Enterprise, and Education editions

Windows Server 2012 R2 x64 - Standard, Datacenter, Essentials, and Foundation editions

Windows Server 2016 x64 - Standard, Datacenter, and Essentials editions

Windows Server 2019 x64 - Standard, Datacenter, and Essentials editions

Even if you are able to get the listener functioning, you will likely recieve other errors with normal database usage that will just cause more headaches in the future which is why it is very strongly NOT RECOMMENDED to install Oracle on an unsupported operating system.

0

Windows 7 is not a supported operating system, period.

Ditch it and re-install this on a current, "server" flavour of Windows.

(Showing my age, here, but ...)
The sleeve notes from the original "Tubular Bells" album seems oddly relevant here:

In Glorious Stereophonic Sound: Can also be played on mono equipment at a pinch.
This stereo record cannot be played on old tin boxes no matter what they are fitted with. If you are in possession of such equipment please hand it into the nearest police station.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.