1

I have an SSIS package that connects MSSQL2008 server to MSSQL2000 and pulls data off the 2000 server and transfers it to the 2008 server. The 2000 server was recently virtualized and since then the SSIS package will not authenticate.

I can see both servers with OSQL -L/sqlcmd -L. All services, agents and browsers are running.

The SQL user that runs the SSIS package can connect via Test Connection button in the Package Explorer>Connection Manager, but when I attempt to execute the package the error output indicates that the login failed, the password does not match. Error 18456 Sev 14 State 8. I am sure the password is correct as I just created the new SQL user to test. Am I missing something that the SSIS package may authenticate somewhere else?

Should the connection string include the password, or does that get pulled form elsewhere in the SSIS package?

I am not a DB admin/SQL guy so please excuse my green-ness if I am overlooking something simple here, which I hope I am. Thanks for any input

2
  • Same questions remain: PackageProtectionLevel, Expressions on Connection Managers, Configuration enabled. dba.stackexchange.com/questions/289883/… – billinkc Apr 21 at 22:42
  • What version of SSIS are you using? Is it running onyour 2000/2008 server or is it running on a 3rd server? SSIS Has improved significanlty since 2008. You may want to consider running it from a newer installation. – Sir Swears-a-lot Apr 22 at 1:51
0

We where able to solve the Connection Problems with the Package Parameter Tab. Here you are able to "Save" for each connection the Username and Password (In clear Text ^^?!). And then the Package can connect.

screenshot from ssis package

2
  • I do not seem to have a parameter tab. Running Server2008. – mcv110 Apr 22 at 13:26
  • Oh sorry i thought they where there already but there where added in 2012 it seems. Sorry. – MisterT Apr 28 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.