0

Running a series of automated checks on our databases for the security folks checking our STIG compliance. Mostly simple stuff like certain parameters turned off, etc. We're in the stone ages, so this is being done with Sqlplus scripting to populate the reports.

Using sqlplus -S to filter out that unnecessary login message, but the security folks would also like the command with the finding details instead of just the output. With sqlplus -S, the output is

VALUE
------
FALSE

whereas we want

Select blah blah;

VALUE
------
FALSE

Set echo on doesn't fix this, even when nesting the query in a sql script and run with @. I'm assuming the S option overrides the echo setting. Wondering if there's an option I'm not familiar with or if I just need to work around it.

1 Answer 1

0

'sqlplus -S' suppresses banners, prompts, and echoing commands.

Cheers,

Russ

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.