0

Good morning all,

I hope anyone can help me with this. I am trying to upgrade an Oracle RAC of two nodes from version 12.2 to 19c. As part of the prerequirements, I have applied the patch 28553832 in both nodes. Opatch and Kfod show both the same patches applied to both nodes

Node 1

$crsctl query crs activeversion -f
Oracle Clusterware active version on the cluster is [12.2.0.1.0]. The cluster upgrade state is [NORMAL]. The cluster active patch level is [1205374555].
$crsctl query crs softwarepatch
Oracle Clusterware patch level on node scglvdoraci0010 is [1205374555].
$crsctl query crs releasepatch
Oracle Clusterware release patch level is [1205374555] and the complete list of patches [26839277 27105253 27128906 27144050 28553832 ] have been applied on the local node.
$ kfod op=patches
---------------
List of Patches
===============
26839277
27105253
27128906
27144050
28553832
$ kfod op=patchlvl
-------------------
Current Patch level
===================
1205374555

Node 2

$crsctl query crs activeversion -f
Oracle Clusterware active version on the cluster is [12.2.0.1.0]. The cluster upgrade state is [NORMAL]. The cluster active patch level is [1205374555].
$crsctl query crs softwarepatch
Oracle Clusterware patch level on node scglvdoraci0010 is [1205374555].
$crsctl query crs releasepatch
Oracle Clusterware release patch level is [1205374555] and the complete list of patches [26839277 27105253 27128906 27144050 28553832 ] have been applied on the local node.
$ kfod op=patches
---------------
List of Patches
===============
26839277
27105253
27128906
27144050
28553832
$ kfod op=patchlvl
-------------------
Current Patch level
===================
1205374555

However, when I run the runcluvfy I got this error

/grid122/app/19.3.0/grid/runcluvfy.sh stage -pre crsinst -upgrade -rolling -src_crshome /grid122/app/12.2.0/grid -dest_crshome /grid122/app/19.3.0/grid -dest_version 19.0.0.0.0 -fixup -verbose

Verifying Oracle patch:28553832 ...
  Node Name     Applied                   Required                  Comment  
  ------------  ------------------------  ------------------------  ----------
  scglvdoraci0009  missing                   28553832                  failed   
  scglvdoraci0010  missing                   28553832                  failed   
Verifying Oracle patch:28553832 ...FAILED (PRVG-1260, PRVG-1261)

My question is how cluvfy is checking which patches are applied and why it is getting this error , when kfod and lsinventory in opatch show both that the patch is applied in both nodes.

Would anyone in this scenario try to upgrade when the requirements are not passed ?

Thank you

2
  • Have you got a support login? There are a couple of notes surrounding this
    – Philᵀᴹ
    May 26, 2021 at 16:43
  • I've got a support login, but I can't find any note about this issue in particular Jun 2, 2021 at 13:44

1 Answer 1

0

Fix action is not needed at this time, as the patches are showing up in lsinventory, then you can ignore the warning about missing patch. Here are the syntax to upgrade with skipping the steps:

./gridSetup.sh -ignorePrereq -skipPrereqs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.