2

In windows 10 , Test connection with a udl file is successful. however, if "Use Encryption for data" was changed the to true. UDL Use Encryption the connection fail with error message:

"[DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security Error.

[DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security Error.

The same message is presented when a simple Delphi app That I wrote to connect the SQL Server. This is the only computer it is happening in. Where to disable the OS rule that require apps to use encrypted connection?

Update:

using the management studio with this configuration will yeild error message: enter image description here

however enter image description here trust server certificate will connect to the server.

i have checked and the server does not have force connection. no certificates are installed.

2 Answers 2

3

try to review wheter the encryption is forced or not:

in sql server configuration manager

  • Expand SQL Server Network Configuration and right-click on Protocols for , then click Properties.
  • On the Certificate tab, unselect certificate.
  • Select No in the ForceEncryption box, then click OK.

To apply the configuration you have to restart sql server.

certificate

force encryption

1
  • i reinstalled the os on the client. and the server stay the same. it worked. it was an windos 10 configuration/error
    – none
    Commented Jun 27, 2021 at 9:28
0

Not a fan of Windows, and just needed to get the database out from a backup file. Did not want to worry about SSL certificates etc. If you are not doing on this production, there is an easy way around it. Simply:

  1. From the screen below, simply click on "Options >>"

enter image description here

  1. Simply unselect "encrypt connection" and select "trust server certificate"

enter image description here

That worked for me! But this should not be used in production!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.