I've used Datagrip for a while with both SQL Server and MySql, but the experience with Oracle has been very different so far. I'm having issues with a lot of basic features I took for granted with the other databases I've worked with. There is little information about these issues in the Datagrip documentation and it's hard to believe that this tool is so lacking for Oracle.

Typical issues:

  • Struggling to synchronize with incoming updates to schema and similar changes(might be performance related)
  • Types, columns, tables, etc. aren't being resolved
  • There are user schema's with connections(e.g triggers) to other tables not owned by itself which I can't see anywhere in Datagrip.

Any input on resources or solutions are much appreciated!

  • 2
    Hi! I am Max from the DataGrip team and I can be the resource and will try to help you. 1. What do you mean by struggling to synchronize? Resources or time-consuming? Oracle system catalogs can be really slow to give the info especially if the schema is big. If you experience performance problems, please contact our support, they will try to help you: jetbrains.com/support 2. Do you have these objects in the database explorer? If they are there, they should be resolved. 3. Valid point! Seems to be youtrack.jetbrains.com/issue/DBE-12578
    – moscas
    Commented Jun 29, 2021 at 11:01
  • Hi Max, thanks for your response! To answer your questions: 1: Yes the schema is enormous, and simple querries, function-calls etc. takes a lot of time (15-20 seconds avg). e.g when i update a trigger it takes some time before my colleagues can see the update 2: There is a lot of usage between user schemas which might be the reason that they aren't resolved. All objects are visible in the explorer Commented Jun 29, 2021 at 11:43
  • 2
    You might want to ping the user by putting the @ sign in front of their name (no spaces) to make sure they see what you've written!
    – Vérace
    Commented Jun 29, 2021 at 12:36
  • @moscas please see comment above ^^ Commented Jun 29, 2021 at 12:55
  • @ØysteinSeel have you tried DataGrip 2023.1 with enhanced Oracle introspection performance? In general, you need to set Introspection Level 1 for your enormous schema and use Refresh Selected Object if you need updates for a specific object. Commented Mar 30, 2023 at 12:18

1 Answer 1


It looks like the Oracle database was not thoroughly introspected. Please enable Introspection Level 1 and Refresh data source.

enter image description here

For updating a specific object, it is recommended to use the Refresh Selected Object action.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.