0

I'm running all Windows 2016 Servers. I've got MS SQL 2016 installed on one. For whatever reason, we cannot connect to the SQL Server unless we enable TLS 1.0 which is obviously not cool.

I found this: https://github.com/MicrosoftDocs/windowsserverdocs/issues/2783 which talks about how TLS 1.2 should be natively enabled across the board. I've verified TLS 1.2 is enabled in the registry on all involved servers. There is another MS doc referred to in the above link that suggests that isn't enough, we may also need to enable ciphers. So I enabled the RC4 ciphers in the registry on both servers, but still no change. Unless TLS 1.0 is enabled, no talk.

I can even go onto the SQL Server, and create a .UDL connection test (to itself) and it also fails unless TLS 1.0 is enabled.

Any ideas?

2

2 Answers 2

1

The built-in Windows drivers for SQL Server didn't get TLS 1.2 support until Windows Server 2019, see KB4580390.

On older Windows you'll have to install newer SQL Server ODBC or OleDB drivers that support TLS 1.2.

1
  • We actually do have the ODBC driver installed. What we ended up having to do was to install the SQL Server Native Client and then the magic worked.
    – Steven
    Jul 12, 2021 at 11:49
1

We had to install the SQL Server Native Client for SQL 2012 (2016 uses this driver as well) and then I upgraded the version of sqlnci on the SQL Server to the same version, then all was happy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.