1

I've recently performed an in-place upgrade of the default instance of a SQL Server 2016 to SQL Server 2019 (CU11).

I'm trying to add the Polybase feature but am unable to resolve this error that occurs during installation:

Error installing SQL PolyBase The proposed new database owner is already a user or aliased in the database. Changed database context to 'DWQueue'. Error code: 0x84BB0001

The following error dialog appears during the installation process

enter image description here

Retry just results in the same message, after clicking Cancel the installation continues and then finishes with the install dialog showing the following:

enter image description here

If I re-run the setup it thinks Polybase is installed (however it's not, connecting using SSMS still informs me I have to install Polybase). I have to manually run msiexec /x {6FDD1CAA-79C4-43B0-9483-5BD503E656DC} to remove it before I can retry.

During setup I provided domain accounts for the service setup, there's nothing else to configure.

Can anyone shed any light on this error and what I can do to install successfully?

Edit

When in the setup process and presented with the Service Accounts screen for Polybase Engine and Polybase Data Movement, the text at the top of the screen states "Microsoft recommends that you use separate account for each SQL Server service."

However if I specify a different Account Name & password for these services it produces an error and you cannot proceed:

enter image description here

7
  • Can you run an Extended Events session or SQL Profiler trace to capture sql_batch_starting during the install phase to see which user is believes already exists?
    – HandyD
    Commented Aug 10, 2021 at 5:18
  • I will hopefully have time today to revisit and will see what I can capture from a profiler trace.
    – sTTu
    Commented Aug 10, 2021 at 9:02
  • Running a trace during the install and logged to table=60k events. Filtering down to applicationname='sqlsetup' and eventclass=13 leaves 420 rows. From these I have found a t-sql script which contains ALTER AUTHORIZATION ON DATABASE::DWQueue TO [domain\my own user name]. Everywhere else it uses the domain account name I entered in Setup for the Polybase services. Running this command in isolation does give the error The proposed new database owner is already a user or aliased in the database.. Is this a bug in the install process?!
    – sTTu
    Commented Aug 10, 2021 at 9:37
  • 1
    Using run as... to specify a different user to run Setup as makes no difference, so out of ideas.
    – sTTu
    Commented Aug 10, 2021 at 10:03
  • 1
    Had one more idea to log on to the server using the domain user account for running the services as and to run setup logged in as that user.... same error.
    – sTTu
    Commented Aug 10, 2021 at 10:11

1 Answer 1

1

So I have found a workaround for this issue.

After determining the error is arising from the installation process trying to add the user account under which the Setup.exe is running to the DW... databases that it creates (where the user already exists).

When the error The proposed new database owner is already a user or aliased in the database. appears I dropped the user (me) from the database and proceeded to retry.

It then continued and raised the same error for the DWDiagnostics database, so I repeated the process to drop myself from that database also.

After which, setup continued and...

enter image description here

So I believe this is a bug with the Polybase installation script, the workaround being to delete the user running the installation from the DW... databases during installation.

2
  • Or just create another user Commented Jun 16, 2022 at 21:35
  • So basically the Administrator cannot install PolyBase? Commented Jun 16, 2022 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.