0

I have tried many times to reinstall Oracle 19c. Every time, when I run setup.exe I get an error on the installation step that says [INS-20802] Oracle Database Configuration Assistant Failed. In error, there is said [FATAL] Error while executing "C:\Users\Farrukh\Downloads\oracle\ORACLE_HOME\rdbms\admin\dbmssml.sql". Refer to "C:\Users\Farrukh\Downloads\oracle\cfgtoollogs\dbca\oracle\dbmssml0.log" for more details. Error in Process: C:\Users\Farrukh\Downloads\oracle\ORACLE_HOME\perl\bin\perl.exe Look at the log file "C:\Users\Farrukh\Downloads\oracle\cfgtoollogs\dbca\oracle\oracle.log" for further details. Oracle Database Configuration Assistant failed.

When I go to "C:\Users\Farrukh\Downloads\oracle\ORACLE_HOME\rdbms\admin\dbmssml.sql", there is written CREATE OR REPLACE LIBRARY dbms_sumadv_lib AS 'C:\Users\Farrukh\Downloads\oracle\ORACLE_HOME\bin\oraqsmashr.dll'; /.

When I go to "C:\Users\Farrukh\Downloads\oracle\cfgtoollogs\dbca\oracle\dbmssml0.log", it's blank.

I deleted Oracle manually several times. Maybe I did something wrong. Is it possible to solve this problem?

3
  • What, exactly, did you do to delete it manually? Since this is on Windblows, a "manual deletion" would include deleting at least two directories, as well as some registry keys. BTW, I never run DBCA as part of database installation. Over the years and versions there have been several problems associated with that. I always ran just the installation, then come back and run DBCA by itself.
    – EdStevens
    Jul 28, 2021 at 13:56
  • I followed all these steps youtube.com/watch?v=EHFbk_6ThAQ. I have tried this method too but couldn't run DBCA by itself. Jul 28, 2021 at 14:12
  • I always utilize the actual documentation, instead of relying on some youtube clip from some unknown entity.
    – EdStevens
    Jul 28, 2021 at 22:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.