0

The instances have the following versions

Source -->

Microsoft SQL Server 2017 (RTM-CU25) (KB5003830) - 14.0.3401.7 (X64) Jun 25 2021 14:02:48 Copyright (C) 2017 Microsoft Corporation Standard Edition (64-bit) on Windows Server 2016 Datacenter 10.0 (Build 14393: ) (Hypervisor)

The database has compatibility level 2017 (140)

Target -->

Microsoft SQL Server 2017 (RTM) - 14.0.1000.169 (X64) Aug 22 2017 17:04:49 Copyright (C) 2017 Microsoft Corporation Developer Edition (64-bit) on Windows Server 2012 Standard 6.2 (Build 9200: ) (Hypervisor)

the database is almost 600GB

When we tried a backup without compression then at the restore we get (no backup sets available to restore) in a few seconds

When we tried a backup with compression then at the restore we get (RESTORE HEADERONLY is terminating abnormally. ) after hours of reading the file.

Both SSMS are latests versions.

3
  • @Aaron Bertrand I patched the target to the same CU level. Still same results. The files were transfered to the target by another technician using a VMware cloud due to very big sizes. Is the possibility high, durring the transfer the data to be corrupted ? in event log i saw the follwing --> (The backup data at the end of "C:\SQL\Data\testnew" is incorrectly formatted ) .. Should i take this for sure that we are talking about corrupted file so the transfer has to be made again ?
    – Ibsp Team
    Sep 2 '21 at 20:59
  • Can you edit teh post and add the full text of the error message? Sep 2 '21 at 21:06
  • 1
    Have you tried running a RESTORE VERIFYONLY to confirm the backup media is valid? That might provide more helpful messages if there is a problem with the backup file.
    – HandyD
    Sep 2 '21 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.