For the dbeaver connection, edit connection (Athena JDBC, i.e. AWS daata lake), "driver properties" tab: I cannot change driver properties schema field (default) anymore.

This used to be an edit box, but now it is a dropdown, and the only value I can access is '?'

Picture of schema dropdown with question mark

Is there a work-around for this?

Obviously, one work-around would be to used the fully-qualified name in the SQL code, e.g. Schema1.Table1, which might be a best-practice anyway, but is there a way to get this to work?

NOTE: I found a Connection settings --> initialization area with a "Default schema" field. This appears to work as a setting (and is retained after I type), but it doesn't work in the actual SQL queries so is of little or no value.

I am using DBEAVER Version (a Windows version, on Windows 10).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.