0

I am trying to take a differential backup of my primary database by connecting to the primary replica, but I can't do that. We use SQL Server 2017 EE with latest CU. Database is in full recovery model and full backups are taken everyday at night. The Copy-only backup option and OK button are grayed out. Could someone help to understand why it is not possible to perform the mentioned action?

enter image description here

3
  • it works) I wonder why this does not work using UI. I use latest version of SSMS. I performed the same experiment in my lab environment and there was no any issue. Interesting behavior.
    – RaufDBA
    Sep 30 '21 at 16:26
  • You are right Sir. Anyway I am going to use T-SQL as you suggested. Thank you for your valuable time.
    – RaufDBA
    Sep 30 '21 at 16:31
  • Only thing I'll add is try uninstalling and reinstalling SSMS and see if that fixes the issue. Otherwise Aaron's workaround should be sufficient.
    – J.D.
    Sep 30 '21 at 19:11
2

It's anybody's guess why the UI is preventing you from being able to use the copy-only checkbox. So I can't give you an answer and don't think it would be productive to throw out guesses. I can offer a workaround (and generally, this is a better way to accomplish just about anything a pointy-clicky UI tries to do for you):

  • Press the Script button
  • Copy the script to a new query editor window
  • Add the COPY_ONLY option manually
  • Voila

If you want a definitive answer in addition to a workaround, you'll probably have to talk to Microsoft, who wrote the code, has source code access, can meaningfully debug if they can reproduce your scenario, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.