2

I am running a fresh install of Windows 11 trying to set up a local SQL server for development.

I installed SQL server 2019 from ISO, however am unable to start the server. Same method of install and ISO works fine on my Windows 10 machine.

I have searched online and have seen similar issues posted.. however have not been able to find a solution or workaround.

Error from Event Viewer:

Faulting application name: sqlservr.exe, version: 2019.150.2000.5, time stamp: 0x5d8a9215
Faulting module name: sqllang.dll, version: 2019.150.2000.5, time stamp: 0x5d8a92a9
Exception code: 0xc0000005
Fault offset: 0x0000000000310093
Faulting process id: 0x48a4
Faulting application start time: 0x01d7becf32875804
Faulting application path: C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Binn\sqlservr.exe
Faulting module path: C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Binn\sqllang.dll
Report Id: 14e3b7c3-b920-45c5-b60b-14054875a8f4
Faulting package full name: 
Faulting package-relative application ID: 

Error Dump:

Fault bucket 1333523691806522765, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: sqlservr.exe
P2: 2019.150.2000.5
P3: 5d8a9215
P4: sqllang.dll
P5: 2019.150.2000.5
P6: 5d8a92a9
P7: c0000005
P8: 0000000000310093
P9: 
P10: 

SQL SERVER ERROR LOG:

2021-10-11 14:38:34.74 Server      Microsoft SQL Server 2019 (RTM) - 15.0.2000.5 (X64) 
    Sep 24 2019 13:48:23 
    Copyright (C) 2019 Microsoft Corporation
    Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 22000: )

2021-10-11 14:38:34.74 Server      UTC adjustment: -4:00
2021-10-11 14:38:34.74 Server      (c) Microsoft Corporation.
2021-10-11 14:38:34.74 Server      All rights reserved.
2021-10-11 14:38:34.74 Server      Server process ID is 18596.
2021-10-11 14:38:34.74 Server      System Manufacturer: 'Gigabyte Technology Co., Ltd.', System Model: 'B450 AORUS PRO WIFI'.
2021-10-11 14:38:34.74 Server      Authentication mode is WINDOWS-ONLY.
2021-10-11 14:38:34.74 Server      Logging SQL Server messages in file 'C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Log\ERRORLOG'.
2021-10-11 14:38:34.74 Server      The service account is 'NT Service\MSSQLSERVER'. This is an informational message; no user action is required.
2021-10-11 14:38:34.74 Server      Registry startup parameters: 
     -d C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\DATA\master.mdf
     -e C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Log\ERRORLOG
     -l C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\DATA\mastlog.ldf
2021-10-11 14:38:34.74 Server      Command Line Startup Parameters:
     -s "MSSQLSERVER"
2021-10-11 14:38:34.74 Server      SQL Server detected 1 sockets with 6 cores per socket and 12 logical processors per socket, 12 total logical processors; using 12 logical processors based on SQL Server licensing. This is an informational message; no user action is required.
2021-10-11 14:38:34.74 Server      SQL Server is starting at normal priority base (=7). This is an informational message only. No user action is required.
2021-10-11 14:38:34.74 Server      Detected 16332 MB of RAM. This is an informational message; no user action is required.
2021-10-11 14:38:34.74 Server      Using conventional memory in the memory manager.
2021-10-11 14:38:34.74 Server      Page exclusion bitmap is enabled.
2021-10-11 14:38:34.84 Server      Buffer Pool: Allocating 1048576 bytes for 663038 hashPages.
2021-10-11 14:38:34.85 Server      Default collation: SQL_Latin1_General_CP1_CI_AS (us_english 1033)
2021-10-11 14:38:34.86 Server      Buffer pool extension is already disabled. No action is necessary.
2021-10-11 14:38:34.89 Server      Query Store settings initialized with enabled = 1, 
2021-10-11 14:38:34.89 Server      The maximum number of dedicated administrator connections for this instance is '1'
2021-10-11 14:38:34.89 Server      This instance of SQL Server last reported using a process ID of 17260 at 10/11/2021 2:36:41 PM (local) 10/11/2021 6:36:41 PM (UTC). This is an informational message only; no user action is required.
2021-10-11 14:38:34.89 Server      Node configuration: node 0: CPU mask: 0x0000000000000fff:0 Active CPU mask: 0x0000000000000fff:0. This message provides a description of the NUMA configuration for this computer. This is an informational message only. No user action is required.
2021-10-11 14:38:34.89 Server      Using dynamic lock allocation.  Initial allocation of 2500 Lock blocks and 5000 Lock Owner blocks per node.  This is an informational message only.  No user action is required.
2021-10-11 14:38:34.90 Server      In-Memory OLTP initialized on lowend machine.
2021-10-11 14:38:34.90 Server      [INFO] Created Extended Events session 'hkenginexesession'

2021-10-11 14:38:34.90 Server      Database Instant File Initialization: enabled. For security and performance considerations see the topic 'Database Instant File Initialization' in SQL Server Books Online. This is an informational message only. No user action is required.
2021-10-11 14:38:34.91 Server      Total Log Writer threads: 2. This is an informational message; no user action is required.
2021-10-11 14:38:34.91 Server      clwb is selected for pmem flush operation.
2021-10-11 14:38:34.91 Server      Software Usage Metrics is disabled.
2021-10-11 14:38:34.91 spid9s      Starting up database 'master'.
2021-10-11 14:38:34.92 spid9s      There have been 256 misaligned log IOs which required falling back to synchronous IO.  The current IO is on file C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\DATA\master.mdf.
2021-10-11 14:38:35.03 Server      CLR version v4.0.30319 loaded.
2021-10-11 14:38:35.08 Server      Common language runtime (CLR) functionality initialized using CLR version v4.0.30319 from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\.
4
  • 1
    @AaronBertrand I have tried this on CU11-13 and all give the same issue. The bottom stack is from the SQL Server LOG folder, only event view is showing an error. Also, not sure if this is related in anyway, but in the SQL LOG it is saying I'm running Windows 10 Pro rather than Windows 11 Pro... Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 22000: ) I am now getting the same failure but with ntdll.dll instead. Oct 11, 2021 at 20:08
  • @AaronBertrand The only logs in that folder are titled ERRORLOG. I am getting this error before the server even boots for the first time. Just removed all SQL related programs as well as Visual Studio and did a reinstall... got the same error at the end of install when it tried to start the server. Oct 11, 2021 at 21:11
  • You're seeing WER output which isn't very helpful for a multitude of reasons. ` Exception code: 0xc0000005` is an access violation, the location isn't helpful due to ASLR since you don't know the base. You'd need to use procdump or such as get an actual dump of the process and check the faulting stack. Normally the errorlog will have this information though it could be happening on a non-SQL server created thread, thus not conforming to the exception handlers that SQL-created threads install. Oct 12, 2021 at 20:28
  • It doesnt work on upgrade, nor on fresh install of Windows 11. I have messaged SQL Server team on Twitter. I am not sure how it will go ahead. If I get anything in response, will post here. Oct 13, 2021 at 3:11

1 Answer 1

0

It looks that it just needs to be installed on second disk, weird, but I tried it and it just works.

Basically you have 2 options:

  • Install the instance on the second disk and leave the shared components on Disk C (it should be greyed out so it is not even option here)
  • Install SQL Server 2019 in a linux container (docker) under WSL2

I tried first option and it worked and my colleague tried second option using docker and WSL2 and it also works

Source and more informations: Microsoft docs - SQL 2019 on Windows 11

2
  • Link only answers are discouraged - please provide some context around your answer that summarizes the solution contained in the link.
    – user212533
    Oct 27, 2021 at 0:22
  • Installing it on a Linux container solved my Issue. Thanks! Mar 7, 2022 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.