1

In Oracle forms and reports when I select oracle home to be

C:\Oracle\Middleware\Oracle_Home

I get

INST-07545: Unexpected Error. java.lang.NullPointerException

as shown :

enter image description here

Now here's another related issue

As an installation requirement I installed Oracle WebLogic Server 14c (14.1.1.0), but I cannot run it, as startWebLogic.cmd fails to start and here's the CMD result and the log file in the following gist.

UPDATE: WebLogic installed 3 Domains and none of them starts

wl_server 
medrec
medrec-spring

I Created new domain called base_domain and the new Domain Works

C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain

Oracle Forms and Reports Error changed after I changed the default temp location but the error changed

INST-07548: The selected distribution does not have any compatible install type for the selected Oracle Home.

INST-07551: Not all dependent featuresets for install type "Forms and Reports Deployment" could be found. The following prerequisites were found to be missing: em_fmc - 12.2.1.4.0wls_server - 12.2.1.4.0 Select a different Oracle Home having all dependencies. Check http://www.oracle.com/pls/topic/lookup?ctx=fmw122140&id=installhome for details about compatible products and install types.

Now I am using

JDK17 

and the generic version of weblogic 608MB

fmw_14.1.1.0.0_wls_lite_generic.jar 

and the latest oracle forms

setup_fmw_12.2.1.4.0_fr_win64.exe

Any Idea what I am doing wrong?

The error say there's incompatibility error, but I am using the latest version of both from the following documentation which states:

Oracle Forms and Reports

Download the Oracle Fusion Middleware Infrastructure distribution from the Oracle WebLogic Server download page.

Download the production distribution for Oracle Forms and Reports from the Oracle Software Delivery Cloud.

5
  • Can you please point out what any of this has to do with database administration?
    – mustaccio
    Oct 21, 2021 at 2:18
  • @mustaccio I did ask in the chat whether these kind of questions are appropriate on this forum and I was told yes plus here's similar questions on this site, if its not feel free to vote to close it
    – ma1169
    Oct 21, 2021 at 2:22
  • 1
    ok, @ma1169 is the problem with installing the Oracle DBMS (and if yes, which version of it), or with some other applications? (the questions mentions "Forms and Reports" and "Weblogic Server") And are these part of the Oracle DBMS or standalone installations? Oct 21, 2021 at 8:08
  • @ypercubeᵀᴹ they are standalone installation, Oracle Forms and reports require oracle DBMS(I am using version 19c) and Oracle weblogic server and both dependencies works now, but still I cannot install the Forms
    – ma1169
    Oct 21, 2021 at 14:53
  • 1
    I found the solution to the problem, it is because I used the current latest version of oracle apps, oracle weblogic 14, and oracle forms 12, it seems their apps is not backward compatible, so i had to install weblogic 12 and it worked
    – ma1169
    Oct 21, 2021 at 18:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.