0

I am using Visual Studio Pro 2019 (16.9.4) and SQL Server Data Tools (16.0.62103.10080) but this happens since the beginning of Visual Studio 2019.

I use the Schema Comparison tool to compare databases/dacpac vs SQL projects. And everything goes fine until one day the comparison does not match the objects from the source and target and suggests a creation and drop of ALL the object in the database as shown here: enter image description here

I believe that something gets corrupted in the project, because from that moment on, the comparison tool is unable to match objects any more.

I've tried to erase *.dbmdl file, change the codification of the files (UTF-8 with/without BOM), erase the project and download it again, etc. but nothing works.

The same database/dacpac against other projects works fine... so it's something about the project!

Any suggestions?

3
  • Sometimes when odd things happen, I flip the target database as a source and the project as a destination to see if the same thing occurs. Other times I right-click on the project and rebuild it. Usually doing one of those exposes or fixes the problem. Have you tried that yet? Oct 26, 2021 at 9:00
  • @AntoineHernandez Thanks for your suggestion. I've tried that, also to compare against different databases or dacpacs, to create a new comparison ... but it's something about the VS SQL Project.
    – Alex
    Oct 27, 2021 at 19:02
  • If you expand the plus sign sometimes it gives a bit more detail too. Anything there? Oct 27, 2021 at 19:13

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.