0

Application aware full backups and log backups are configured in the veeam settings as shown in screenshot below.

enter image description here

I want to modify the settings such that full backups are using the copy only mode. However, the perform copy only radio button is only applicable to transaction log (as shown in the section header). How to configure copy only full backup in veeam?

Reason why I want to apply copy only full backup mode is - otherwise (without the copy only mode) the full backup breaks the differential backup chain.

1

That option confusingly enough means that Veeam will do copy only for the snapshot full backup, not the log backups. The GUI is confusing.

I suggest you change that option to "Perform copy only" and then (re)visit the backup history tables to verify that the full snapshot backup is done using copy_only.

I don't have an environment where I can test this, so I consulted a whitepaper I wrote for Veeam 5 years ago. Back then I did have access to an environment so hopefully the information in that WP is correct (it was proof-read as well :-) ).

Here's a quote from that WP:

"As for the “Transaction logs” option, you want to select “Perform copy only” if you perform your own SQL Server backups. This way the Veeam snapshot backup will be seen by SQL Server as a COPY_ONLY backup and will not interfere with any differential backups that you produce in SQL Server. "

You can find it here, https://www.veeam.com/wp-sql-server-backup-with-veeam.html. I think that you can get to the pdf by registering and also get the screenshots that way.

7
  • In the msdb.dbo.backupset table, the backup is recorded with type D and is_copy_only 0. This means that it is not a copy only backup.
    – variable
    Nov 1 '21 at 8:50
  • Where can I do this check - Check the backup history for your Veeam snapshots? I was expecting that is_copy_only value should have been 1 if it was a copy only backup.
    – variable
    Nov 1 '21 at 8:52
  • I wrote a whitepaper for Veeam about 5 years ago and I consulted that WP. I added some info in my above answer. Nov 1 '21 at 11:35
  • Looks like the answer is not updated. Please can you check again.
    – variable
    Nov 1 '21 at 11:40
  • It is updated now. Nov 1 '21 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.