0

Using mssms I can start to configure replication utilsing the wizard. At the end the wizard states Replication success and publication server success.

Step 2 is to create a publisher. Here is where the problems start. I right click on publisher > new publisher - I then get the error that the server must be enabled as a publisher. I enable it and still get the same error.

When I look in the log files under /var/opt/mssql/log/errorlog I am seeing a lot of errors relating to .dll's - such as "xprepl.dll".

I thought replication was supported on mssql-server 2019 for Linux but it does not seem to matter what I do I cannot get a publisher successfully set up and configured.

Anyone else seen this issue please?

6
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Nov 10 '21 at 15:37
  • Did you try the tutorial?
    – SMor
    Nov 10 '21 at 22:55
  • Yes, tutorials followed from an SQL command line perspective and also from the mssms gui.
    – CliveG
    Nov 11 '21 at 10:09
  • Yes, I utilised both tutorial. SQL Command Line and MSSMS GUI. There are differences in that from the command line (SQL code) I may be able to get this working if I could work out how to set the admin user as it won't let me apply the code without that being present. On the GUI, when expanding the DB section on the left you end up with a "replication" option. Under this option is to configure the publisher. But it keeps telling me that the server must be enabled. When I check in Distributor properties the server is enabled as a publisher but I cannot create a new publisher.
    – CliveG
    Nov 11 '21 at 10:12
  • Apologies, I am not too sure how to add screenshots here as that would be easier.
    – CliveG
    Nov 11 '21 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.