0

I'm facing the error Maximum supported database size on SQL Server Express edition is: 10 GB. when executing the restore procedure msdb.dbo.rds_restore_database.

The weird thing is the actual database seems not to hit the 10 GB size.
One indication of that is I can perform the restore on my local environment (using the same .bak file).

Furthermore, sp_helpfile confirms that the database size is smaller than 10GB, as showed on attached print.

enter image description here

New contributor
Theo B is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
7
  • 2
    Does this answer your question? SQL Server 2016 Express restore size limit
    – mustaccio
    Nov 25 at 16:30
  • My guess is that there is some compression involved and at restore time, the database is created with a larger size than it will end up eventually. the "normal" restore command does just this for performance reasons, and you can disable it using a trace flag. Perhaps the RDS way will temporarily make it so but so the size limit prohibit the restore, then though the final size would be OK? Nov 26 at 14:53
  • @mustaccio Thanks for the ref. I tried the command RESTORE FILELISTONLY FROM DISK = '/path/foo.bak' and the size column is showing only 8,24 GB (not counting the transactions log file).
    – Theo B
    Nov 26 at 16:42
  • @TiborKaraszi Seems a good guess, but I'm not getting the limitation error when restoring in my local environment. For testing purposes, I'll try to drop a significant volume of data and retry the backup/restore process.
    – Theo B
    Nov 26 at 16:48
  • Are you using msdb.dbo.rds_restore_database on your local environment? My guess is based on this proc does things differently than the native restore command. yesterday

Your Answer

Theo B is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.