1

I'm getting the error "ORA-01109: database not open" in Oracle SQL Developer, in Oracle Database 19c and SQL Developer 21.2.1 Windows 64-bit.

I've gone into SQL Plus to open the database and used commands like "ALTER DATABASE OPEN;" and shut down/restart the instance to open the database. It was originally on Status "MOUNTED," but it now says Status is "OPEN" when entering the command "select instance_name, status from v$instance;" (instance_name is listed as "orcl"). However, I still get the same ORA-01109 error when opening my database, "CS4347" in Oracle SQL Developer. How can I open this database in Oracle SQL developer? This error occurs when I try to expand the database or connect to it.

4
  • If multitenant, check the status of your pluggable databases: SQL>show pdbs Dec 1, 2021 at 19:49
  • @BjarteBrandt i got: SQL> show pdbs; CON_ID (2, 3) / CON_NAME (PDB$SEED, ORCLPDB) / OPEN MODE (READ ONLY, MOUNTED) / RESTRICTED (NO); Is "MOUNTED" corresponding to ORCLPDB the problem here?
    – kike
    Dec 1, 2021 at 20:04
  • please update your question and format your findings. Dec 1, 2021 at 20:34
  • Its already opened but still getting the same error while making connection in Oracle SQL Developer software. stackoverflow.com/questions/70706962/…
    – Kamlesh
    Jan 14, 2022 at 7:09

1 Answer 1

1

With Oracle multitenant your can open the pdb and save the state:

sqlplus / as sysdba # to the CDB
alter pluggable database orclpdb open;
alter pluggable database orclpdb save state;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.