0

I am using Mysql 8.0 in Laragon on Windows 10.

Apparently, I did something which made MySQL stop working. Tried to restart several times but it's showing this same error again and again.

2021-12-15T08:24:35.815298Z 0 [Warning] [MY-010097] [Server] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
2021-12-15T08:24:35.815417Z 0 [System] [MY-010116] [Server] D:\laragon\bin\mysql\mysql-8.0.13-winx64\bin\mysqld (mysqld 8.0.13) starting as process 14852
mysqld: File '.\binlog.000327' not found (OS errno 2 - No such file or directory)
2021-12-15T08:24:42.400102Z 0 [ERROR] [MY-010958] [Server] Could not open log file.
2021-12-15T08:24:42.400850Z 0 [ERROR] [MY-010041] [Server] Can not init tc log
2021-12-15T08:24:42.401518Z 0 [ERROR] [MY-010119] [Server] Aborting
2021-12-15T08:24:43.574538Z 0 [System] [MY-010910] [Server] D:\laragon\bin\mysql\mysql-8.0.13-winx64\bin\mysqld: Shutdown complete (mysqld 8.0.13)  MySQL Community Server - GPL.

I do not understand why it's showing. So I looked into the directory.

Mysql Binlog files

Clearly the binlog.000327 file is missing. Now on google search, I could not find any solution on how to resolve this specific problem.

Should I copy binlog.000326 and rename it binlog.000327? Will it work?

I'm skeptical of doing this because it's a binary file and it might cause other issues such as database data loss.

Or is there a proper fix to this solution?

1 Answer 1

0

NO. Do not fiddle with the files.

Instead...

What probably happened was that the Primary crashed in the middle of sending stuff to the Replica.

This may prevent the problem in the future:

sync_binlog = 1

To get things going again. Well, I need to know some more things:

  • Are you using Replication?
  • Which server (Primary and/or Replica) crashed?
  • What was going on just before the problem?
2
  • I'm not using any replication. I don't even know what replication is. I'm using Mysql 8.0 in Laragon for development. Laragon is like Xampp or Wampp tool in which the DB crashed. I changed the port of apache and Nginx and after the restart, the DB crashed. I fixed it by disabling the bin log in some conf file if I'm correct. I don't know what happened and how to properly fix it. Commented Dec 17, 2021 at 5:05
  • Strange. Sorry, but there are too many details missing; I don't know what to ask for.
    – Rick James
    Commented Dec 17, 2021 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.