The state of the system when I started was that there was a single, working instance of Oracle Database 9i. I proceeded to install Oracle 11g choosing to Install Software Only. Upon completion, everything still worked fine. I created a new 11g listener on port 1522 called LISTENER, which was the same name as the 9i listener listening on port 1521. I don't know if things still worked at this point. Next, I started creating an 11g database which I gave the same SID as the pre-existing 9i database. The database creation process failed at first, and I didn't read the error messages. I ran it again, and no error messages came up. It was at this point when people started complaining about being kicked out of the database.

Upon investigation, I found that it was completely impossible to connect to the once flawless db instance. I tried a myriad of things to get connected to no avail. Finally, I decided I would be better off creating a separate instance and accessing the datafiles from there. This is what brings me here. I have tried creating an instance with the same datafile names and copying the originals into the directory, but I don't know what the original configuration is so that inevitably failed. If anyone has any advice on how I can gain access to the datafiles without knowing the original configuration, I would greatly appreciate it.

OS: Windows Server 2003 R2

Pastebin of 9i alert.log here.

  • Windows or Linux? Is the 9i software still installed? – Philᵀᴹ Dec 15 '12 at 4:26
  • What I think happened: The first DB creation failed because it tried to overwrite a file that was already being used by the 9i database. This crashed the 9i database. The 9i DB crashing allowed the 2nd 11g database creation attempt to succeed. I suspect this will have overwritten the 9i SYSTEM tablespace datafile (and probably controlfile), which unfortunately makes things unrecoverable. Firstly we need to establish if this is what happened. Can you pastebin the alert.log for the 9i and 11g databases, along with the dbca creation logs? Note that you can't just attach data files to sort this! – Philᵀᴹ Dec 15 '12 at 4:54
  • I can say for certain that the 11g database creation did NOT overwrite the SYSTEM tablespace datafile because the 11g database exists under C:\app\administrator\... and the 9i database exists under C:\orant\<SID>. The thing I know that did get overwritten was the Windows Service which takes the form OracleService<SID>. I'll go get those logs... – Stuporman Dec 15 '12 at 5:19
  • 2
    All you'll need to do is recreate the service with oradim, making sure you're using the 9i ORACLE_HOME service and tools - take a backup first! Doing a 9i->11g upgrade is a different matter, and you're best asking a new question about that. – Philᵀᴹ Dec 15 '12 at 19:30
  • 1
    Phil, you were absolutely 100% correct. Thank you, mate. If you could put that in an answer, I'll accept it and upvote it. – Stuporman Dec 16 '12 at 4:25

Seeing as you have stated that the original data files look like they're untouched, all you need to do is recreate the service with oradim, making sure you're using the 9i ORACLE_HOME service and tools.

| improve this answer | |
  • I used the example to create a new instance on this page. – Stuporman Dec 19 '12 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.