0

I installed postgres like this:,

  • sudo apt install postgresql postgresql-contrib
  • sudo systemctl is-active postgresql, returned active
  • sudo systemctl is-enabled postgresql, returned enabled
  • sudo systemctl status postgresql, returned active

but when I try confirming if the Postgresql server is ready to accept connections from clients as follows:

  • sudo pg_isready, this returned /var/run/postgresql:5432 - no response.

I've tried all with no success please help, thanks in advance.

OS: Linux Mint "Uma"

1 Answer 1

0

I edited postgresql.conf:

sudo nano /etc/postgresql/9.3/main/postgresql.conf

Enable or add:

listen_addresses = '*'

Restart the database engine:

sudo service postgresql restart

Also, you can check the file pg_hba.conf:

sudo nano /etc/postgresql/12/main/pg_hba.conf

And add your network or host address:

host    all             all             192.168.1.0/24 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.