1

enter image description here

I have newly installed MySQL 8 and PhpMyAdmin. I did all the installation steps properly. but once i get login to PhpMyAdmin by root user, it always gives an set of errors at the bottom of page saying -

The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. Find out why.
Or alternately go to 'Operations' tab of any database to set it up there.

mysqli_real_connect(): (HY000/1045): Access denied for user 'phpmyadmin'@'localhost' (using password: YES)
Connection for controluser as defined in your configuration failed.

1 Answer 1

0

You appear to have instructed phpMyAdmin to use the "Configuration Storage" database (which gives you extra features such as bookmarking queries), but the associated user doesn't seem to exist or have proper permissions.

You can remove the configuration directive that is telling phpMyAdmin to use the advanced features by editing config.inc.php and setting $cfg['Servers'][$i]['pmadb'] to a blank string, like $cfg['Servers'][$i]['pmadb'] = '';

There is a chance the use, called the controluser, is misconfigured. If the user appears to exist in your phpMyAdmin, then probably either the host field or password are incorrect.

Assuming it doesn't exist, you could create the missing user, using the username and password you define in config.inc.php for the controluser and controlpass fields:

With MariaDB:

CREATE USER 'pma'@'localhost' IDENTIFIED VIA mysql_native_password USING 'pmapass';
GRANT SELECT, INSERT, UPDATE, DELETE ON `<pma_db>`.* TO 'pma'@'localhost'; 

For MySQL 8.0 and newer:

CREATE USER 'pma'@'localhost' IDENTIFIED WITH caching_sha2_password BY 'pmapass';
GRANT SELECT, INSERT, UPDATE, DELETE ON <pma_db>.* TO 'pma'@'localhost';

For MySQL older than 8.0:

CREATE USER 'pma'@'localhost' IDENTIFIED WITH mysql_native_password AS 'pmapass';
GRANT SELECT, INSERT, UPDATE, DELETE ON <pma_db>.* TO 'pma'@'localhost';

See also:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.