0

I'm having a problem with importing data. I created a package in SSIS and a connection between SSIS and sql server. It all works fine outside SQL Server but I wanted to make a 'Job' SQL Server Agent, I created a 1 step job (import) and scheduling. When I want it to run I'm getting an error like this. Please, any tips are welcomed. I'm sending a screen from the raport enter image description here

New contributor
Alexander Valdez is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
3
  • After addressing the point in Andrey's answer, you'll next need to verify you have are running the correct bit'edness of the drivers (32 vs 64). 64 will be the default and it might work but if it does not, go to the Advanced settings of the job step and there should be a checkbox for Use 32 bit runtime
    – billinkc
    Jan 13 at 18:05
  • Unfortunately I don't see this option. I checked advanced settings of my job's step and could not see that checkbox. I only see the options to choose whether action is succeed or not Jan 14 at 7:16
  • For future reference, the setting I spoke of is available in the SSIS Job Step, under Configuration -> Advanced 👀 i.stack.imgur.com/iiIaq.png
    – billinkc
    Jan 14 at 12:55
2

It looks like the owner of the SQL Agent job doesn't have access to the personal folder of user Aluka. If you use more public folder, it will have more chances to work.

2
  • How do I do give the access to this folder, sql agent and the folder are placed on the same drive Jan 14 at 7:18
  • Thanks, I changed sharing option in properties of this folder. It worked like a charm. I was looking for solution in different places. And here we are, couple 'clicks' was enough thank you. Jan 14 at 7:26

Your Answer

Alexander Valdez is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.