2

In order to allow me to rename a database I set it to single-user mode. The rename worked fine but now trying to open the DB or even view its properties gives me connection errors. I've tried restarting SMSS but to no avail. All I wanted to do was rename it now I'm stuck. SMSS is generally acting very flaky.

What has gone wrong and how do I fix it? I'm running on Windows.

3
  • Make sure you have closed Object Explorer (and any other SSMS query windows you have open). Commented Jan 21, 2022 at 20:01
  • Is the database still in single user mode? Commented Jan 21, 2022 at 20:12
  • I couldn't get it out of single-user mode as I couldn't connect. I ended up deleting and recreating (luckily it's a new DB or this wouldn't be an option). Even then this was problematic but I got it to work.
    – Mr. Boy
    Commented Jan 24, 2022 at 9:43

1 Answer 1

1
  1. restart sql server
  2. open SMSS and login to sql server
  3. on a new query run ALTER DATABASE dbname SET MULTI_USER; to set your db to back to Multi-user

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.