0

I'm trying to setup a new dev environment. I have installed a Windows Server 2022 with SQL Server 2019 on it.

My idea is to setup a new instance for every project I make.

But I'm having trouble installing new instances and connecting to them remotely.

What I do:

Start setup -> create new instance -> put in instance name let the wizard finish.

To access remotely, I went to configuration manager and enabled tcp/ip and named pipes.

I restarted all services.

In the firewall port 1433 tcp and port 1434 udp are enabled.

My default instance sqlexpress is accessible for remote connection, So I can definitely say it is not a firewall issue.

I currently tried 3 times where the first time I was able to connect locally but not remotely, other 2 time failed to even connect locally even after restarting my virtual machine. Locally and remotely I'm getting error 26. googling around doesn't find the right answer.

services

configuration manager

firewall

Can anyone explain what I'm doing wrong and or give me the steps to install a new instance and allow it to connect remotely?

8
  • 2
    What TCP/IP port(s) is the NETWORKMONITOR instance listening on? Only one instance can be listening on tcp/1433 on any particular address, so if the SQLEXPRESS instance was already listening there then the new instance must be listening on a different port. Feb 20 at 11:09
  • 1
    Each instance is on a separate port. You need to open the firewall to sqlservr.exe on any port. Feb 20 at 13:56
  • ow, that's a good point, I didn't knew that. I was thinking about that too but rather weird that I was able to connect locally. I have connected to server with multiple instances withouth the need to enter a port in the connectionstring or via ssms Feb 20 at 18:56
  • 1
    You don't use SSMS for this. You use the "SQL Server Configuration Manager" tool. Feb 21 at 9:12
  • 1
    Does this answer your question? Setting Up Named SQL Server Instance Network Connection
    – Doug Deden
    Feb 21 at 14:57

1 Answer 1

0

In my case, My problem was both instances were listening to the same port. When replacing the ports by changing to a seperate port for each instance, everything works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.