-3

enter image description hereWhen I try to backup a database, it is showing this message :

to accomplish this action set property devices. (microsoft.sqlserver.smoextended)

I cannot able to select the file location to backup as you can see in the picture that OK button is not enabled.

I tried to change the permission of folders, but the permissions are not changing.

Note: I am using MS SQL Server -2022- 2019

8
  • @Ronaldo yes I am using the wizard and I attached the screenshot along with it Apr 11, 2022 at 22:59
  • What version of SSMS?
    – J.D.
    Apr 11, 2022 at 23:10
  • 18.11.1 developer edition @J.D. Apr 11, 2022 at 23:29
  • 1
    If you are using SQL Server 2022, you are probably under NDA for an unreleased product and have direct access to people who can answer your questions. Your screenshot indicates that you're probably using SQL Server 2019.
    – alroc
    Apr 11, 2022 at 23:30
  • 1
    "I tried to change the permission of folders, but the permissions are not changing." what does that mean, what did you do? You need to give permissions to the SQL Server service account Apr 12, 2022 at 11:21

2 Answers 2

2

I see you are using SQL 2019, not SQL 2022. I can see this from both object explorer and also from the backup path. The number 15 is for SQL 2019. SQL 2022 is still in private preview and not yet publicly available.

I've included a screenshot of how to take a backup using the wizard in SSMS. The OK button is disabled until you enter a name for the backup file.

enter image description here

0

If you're having issues with permissions, just pick a different folder where SQL server does have access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.