3

All updates are installed on VS 2017 (15.9.47) and 2019 (16.11.13)

I am trying to perform a data comparison between two DB's via Microsoft’s tool , On Prem and Azure SQL managed instance Everything has been working fine for the last few months

I changed my password last week , this is the only thing I can see causing issue? When I changed my password previously , I had no issues , maybe coincidence

• I can connect to the Azure SQL managed instance in SSMS with new password • I can connect to the Azure SQL managed instance in SSDT with new password

Issue

In SSDT 2017/2019 --> Tools --> SQL Server --> New data comparison --> Select connection

Select the Azure SQL managed instance , click connect --> connecting --> prompts for my password No error --> in the Source Database still illustrates "choose a database" (should illustrate the Azure SQL managed instance)

• Using On-prem Server connects fine

I tried

  1. Reset Password again
  2. created a new connection to the Azure SQL managed instance in SSDT with new password , I can see all databases in the drop down , no errors, appears to connect
  3. Same issue in SSDTSchema comparison tool, unless using Azure data studio Schema comparison tool
  4. Remove account from visual studio ,add in VS account again with new password
  5. I can Query the Azure SQL managed instance in VS
  6. Verified all settings in the connection string(advanced) are the same
  7. Installed VS 2019 SSDT and SQL server data tools , same issue

1 Answer 1

5

A recent update to Azure SQL Managed instance broke some SSDT functionality as described in this MS Q&A thread.

As described in the comments, the data comparison tool issue is fixed with Visual Studio 2022 17.1.3 and SSDT schema compare works in Visual Studio 2022 17.2.0 Preview 3.

1
  • Thanks, I asked Microsoft on there and they said none of their customers are having this issue , nightmare when this stuff stops working, waste days scratching your head
    – TSide
    Apr 23, 2022 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.