0

I'm attempting to add an index to a very large table (2B rows) and the command fails after a few hours with:

ERROR 1030 (HY000): Got error 100 - 'InnoDB error' from storage engine

I'm finding the InnoDB 100 error code to be ungoogleable. It seems to be running out of some kind of resource, but the server has 128 GB of RAM and tons of disk space. Mysql isn't crashing.

I think maybe I need some config tweaks to give it more juice, but I don't know where to start.

Server version: Server version: 8.0.28
Db engine: InnoDB

1 Answer 1

0

Perhaps the setting for tmpdir is pointing into a small disk partition. Check

SHOW VARIABLES LIKE 'tmpdir';
1
  • This was indeed the cause. The root partition filled up to 100% because of temp tables in /tmp. Then the query failed and the disk usage got freed. Moving the tmpdir to a larger partition has solved it.
    – Minsc
    May 6 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.