-2

I renamed a stored procedure using sp_rename system stored procedure but now I am unable to find it in the database in the SSMS browser. I have refreshed the IntelliSense Cache also, and restart the server also but still cannot find the procedure, does anyone know a way to find the lost stored procedure?

New contributor
pnmhtkr is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
4
  • 1
    Please note the docs on sp_rename caution not to use it on stored procedures. What do you mean by "not able to find it"?...as in you don't see it in the Object Explorer in SSMS? What happens if you try scripting it to run, e.g. EXEC spYourProcedureNewName?
    – J.D.
    Jun 20 at 11:36
  • not able to see in object explore in SSMS. if I run exec using old as well as new name of sp it gives "Could not find stored procedure" error
    – pnmhtkr
    Jun 20 at 13:00
  • and i checked in sys.objects command it showing new sp name. and when i run sys.sql_modules definition showing with old name. but when i use exec command to run sp using old as well as new name it giving error "Could not find stored procedure".
    – pnmhtkr
    Jun 20 at 13:02
  • sp_rename does not effect sql_modules. github.com/MicrosoftDocs/sql-docs/pull/7664 redeploy the proc from source if you want that catalog updated Jun 23 at 16:24

0

Browse other questions tagged or ask your own question.