SQL Server is still working smoothly but I noticed that I have an alert on the Windows Update that says:

Servicing Update for SQL Server 2019 RTM GDR (KB4517790) 
Install error - 0x80070643

enter image description here

I tried to reboot and update sever times but it's still not installing.

So I downloaded the KB4517790 but when I try to install the service stops with the error:

There are no SQL Server instances or shared features that can be updated on this computer.

enter image description here


I click back twice and I check the View detailed report and everything is fine:

Microsoft SQL Server 2019 - System Configuration Check Report
Rule Name Rule Description Result Message/Corrective Action
PatchGlobalRules: SQL Server 2019 Setup configuration checks for rules group 'PatchGlobalRules'
# Engine_ResourceDLLUpdateRestartCheck Checks whether shared resource DLLs will be updated, causing restarts for clustered SQL Server instances active on this node. Not applicable This rule does not apply to your system configuration.
# AclPermissionsFacet Checks if the SQL Server registry keys are consistent. Passed SQL Server registry keys are consistent and can support SQL Server installation or upgrade.
# Cluster_IsLocalNodeGroupOwner Checks if the local computer is an owner of an online cluster group for a failover cluster instance that contains the SQL Server service, Analysis Services service or a generic service. Passed The local computer is not an owner of an online cluster group for a failover cluster instance that contains the SQL Server service, Analysis Services service or a generic service. The SQL Server instances do not need to be taken offline.
# Cluster_IsOnlineIfClustered Verifies that the computer is not clustered or that the computer is clustered and the cluster service is online. Passed The computer is either not clustered or the cluster is up and online.
# RebootRequiredCheck Checks if a pending computer restart is required. A pending restart can cause Setup to fail. Passed The computer does not require a restart.
# ThreadHasAdminPrivilegeCheck Checks whether the account running SQL Server Setup has administrator rights on the computer. Passed The account running SQL Server Setup has administrator rights on the computer.
# WmiServiceStateCheck Checks whether the WMI service is started and running on the computer. Passed The Windows Management Instrumentation (WMI) service is running.

So I found a fantastic command in PowerShell that allows me to recover all Windows Update logs.

I type Get-WindowsUpdateLog and a file called WindowsUpdate.log is now on my Desktop.

When I open it I find:

2022/07/12 11:35:06.5502777 14516 14848 ComApi          Byte length of the input buffer for deserialization: 36024
2022/07/12 11:35:06.5518950 14516 14848 ComApi          Deserialized installable update Servicing Update for SQL Server 2019 RTM GDR (KB4517790), UpdateID = {CA10020A-BECD-4535-B06D-E30E92F01AD6.200}
2022/07/12 11:35:06.5521232 14516 14848 Test            AUTest.cab validation: Test keys are not allowed
2022/07/12 11:35:06.6192658 14516 8864  ComApi          Serializing CUpdate CA10020A-BECD-4535-B06D-E30E92F01AD6.200, Last modified time 2022-07-12T09:25:10Z
2022/07/12 11:35:06.6198416 14516 8864  ComApi          Update serialization complete. BSTR byte length = 36024
2022/07/12 11:35:21.4414511 21868 24160 Agent           Earliest future timer found: 
2022/07/12 11:35:21.4414806 21868 24160 Agent               Timer: 29A863E7-8609-4D1E-B7CD-5668F857F1DB, Expires 2022-07-12 12:48:15, not idle-only, not network-only
2022/07/12 11:35:22.4513120 21868 25304 Shared          UninitializeSUS
2022/07/12 11:35:22.4513184 21868 25304 Misc            CSusClientGlobal::DoServicePreShutdown
2022/07/12 11:35:22.4517025 21868 25304 IdleTimer       Idle timer disabled in preparation for service shutdown
2022/07/12 11:35:22.4517139 21868 25304 Misc            WUTaskManager uninit
2022/07/12 11:35:22.4517196 21868 25304 Agent           Earliest future timer found: 
2022/07/12 11:35:22.4517386 21868 25304 Agent               Timer: 7971F918-A847-4430-9279-4A52D1EFE18D, Expires 2022-07-12 10:37:14, not idle-only, network-only
2022/07/12 11:35:22.4683034 21868 25304 Misc            CreateSessionStateChangeTrigger, TYPE:2, Enable:No
2022/07/12 11:35:22.4683300 21868 25304 Misc            CreateSessionStateChangeTrigger, TYPE:4, Enable:No
2022/07/12 11:35:22.4916515 21868 25304 Misc            Agent uninit
2022/07/12 11:35:22.4916711 21868 25304 Agent           *FAILED* [8007139F] file = onecore\enduser\windowsupdate\client\engine\handler\cbs\lib\uhcbs.cpp, line = 4848
2022/07/12 11:35:22.4916832 21868 25304 DownloadManager Exiting CDownloadHandlerCallbackHandler::Uninit within timeout bounds
2022/07/12 11:35:22.4925943 21868 18656 Agent           Deployment session (host process 21868) signalled to exit...
2022/07/12 11:35:22.4926590 21868 18656 Deployment      Deployment job Id 3A2949A0-E56C-4FA1-AB01-8282F1D469DA : Destructor invoked for deployment job.
2022/07/12 11:35:22.4926639 21868 18656 Deployment      Deployment job Id 3A2949A0-E56C-4FA1-AB01-8282F1D469DA : WaitForEnd invoked for deployment job. Beginning the wait now!
2022/07/12 11:35:22.4926702 21868 18656 Deployment      Deployment job Id 3A2949A0-E56C-4FA1-AB01-8282F1D469DA : WaitForEnd for deployment job completed. Job state = Complete
2022/07/12 11:35:22.4942066 21868 25304 Misc            Reporter uninit
2022/07/12 11:35:22.4943410 21868 25304 Misc            network cost manager uninit
2022/07/12 11:35:22.4943651 21868 25304 Misc            Eventer uninit
2022/07/12 11:35:23.5095262 21868 25304 Misc            ServiceManager uninit
2022/07/12 11:35:23.5098089 21868 25304 Misc            PersistentTimeoutScheduler uninit
2022/07/12 11:35:23.5098136 21868 25304 Misc            datastore uninit
2022/07/12 11:35:23.5630608 21868 25304 Misc            setting cache uninit
2022/07/12 11:35:23.5630619 21868 25304 Misc            security checker uninit
2022/07/12 11:35:23.5630660 21868 25304 Misc            Test Hook uninit
2022/07/12 11:35:23.5630667 21868 25304 Misc            IdleTimer uninit
2022/07/12 11:35:23.5635012 21868 25304 Shared          * END * Service exit Exit code = 0x240001

I see something is falling but I don't know how to move.

I have already tried to SQL Server Repair and it didn't help.

I'm on the latest version:

Microsoft SQL Server 2019 (RTM-CU16-GDR) (KB5014353) - 15.0.4236.7 (X64)   May 29 2022 15:55:47   Copyright (C) 2019 Microsoft Corporation  Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 22000: ) (Hypervisor) 
  • 1
    If you are on latest version what is point in installing the the lower version KB4517790 ? This will ofcourse not be allowed. The problem here seems with automatic updates as to why it is trying to install this KB when you SQL Server is at CU16 level.
    – Shanky
    Commented Jul 12, 2022 at 10:40
  • You are right @Shanky, is there any other log I should look into? Commented Jul 12, 2022 at 10:42
  • 1
    You are asking logs to look as to why automatic update is throwing old update or you want to check why SQL Server update failed ? . Guess you know the answer for later
    – Shanky
    Commented Jul 12, 2022 at 10:47
  • @Shanky, I'm asking because I'm not really sure how to move. Thanks to you I now understand that Windows Update is trying to install something older than my installation and it shouldn't do that. But why is this happening. Should I just leave it like that? Commented Jul 12, 2022 at 12:07
  • You can definitely ignore it. See if this thread helps you in disabling it
    – Shanky
    Commented Jul 12, 2022 at 12:17

2 Answers 2


I solved the problem.

I searched on Microsoft support for the KB4517790 and I found this page: KB4517790 - Servicing Update for SQL Server 2019 RTM

Here I Downloaded the latest cumulative update package for SQL Server 2019

And when the installation finished the problem was solved.


For me the reason of the same error was because I've added Master Data Services feature after the mentioned update was installed. Just re-install the mentioned update manually again it should solve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.