1

I am working on testing a particular software issue that requires the use of a MS SQL installation on a Windows Failover Cluster.

For various reasons I can't use an AD Domain for this particular testing, so I have set up the Windows Failover Clustering without that, and it is working fine.

The problem comes when I go to install MSSQL 2019 and it asks me which accounts to use for the SQL Server Agent and SQL Server Database Engine.

Nothing works -- NT AUTHORITY\LOCAL SERVICE doesn't work, nor does NT SERVICE\MSSQLLFDLauncher, nor does the built-in Administrator, nor does the cluster admin (clustadm) account I have created on both nodes.

The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.

Microsoft.SqlServer.Configuration.Agent.InputValidationException: The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.

It keeps asking me for a Domain Account but that isn't an option here. Is there some workaround?

1
  • 1
    Are you installing an FCI or an AG? You must be domain joined to use an FCI but you don't need to be for an AG. Commented Aug 16, 2022 at 19:00

1 Answer 1

0

I'm facing the same issue. I'm afraid Always On Availability Groups are supported on workgroup. See post from Edwin M Sarmiento (Microsoft Certified Master/Solutions Master) https://social.msdn.microsoft.com/Forums/en-US/3ba18080-2ab8-4444-bd17-74a39f4202a0/unable-to-install-sql-cluster-in-workgroup?forum=sqldisasterrecovery

1
  • Please avoid posting link-only answers as links do go dead over time.
    – user212533
    Commented Oct 28, 2022 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.