In an attempt to fix another issue I had, I ran the commands below (as per https://dev.mysql.com/doc/refman/5.6/en/old-client.html)

mysql> UPDATE mysql.user SET plugin = 'mysql_old_password'
mysql> WHERE User = 'root' AND Host = 'localhost';
    -> 'root'@'localhost' = OLD_PASSWORD('new_password');

And now I'm unable to even get access to mysql through mysql -u root because it gives me the error ERROR 1524 (HY000): Plugin 'mysql_old_password' is not loaded. I can't run mysqladmin and sudo mysqld_safe --skip-grant-tables gives me the error

[1] 51759
my-username@Macbook-Pro ~ % 
[1]  + suspended (tty output)  sudo mysqld_safe --skip-grant-tables

When I tried to run mysqld --old-password=1 I got a whole lot of 2022-08-17T11:10:18.149573Z 1 [ERROR] [MY-012574] [InnoDB] Unable to lock ./ibdata1 error: 35

I have tried uninstalling and reinstalling using homebrew for macOS, when that didn't work I also tried manually installing mysql from the website but that didn't work either.

(I use mysql version 8.0.30 for macOS 12.4)

1 Answer 1


Was given the following post on GitHub to properly uninstall MySQL so that I could reinstall it again and have it work correctly: https://gist.github.com/vitorbritto/0555879fe4414d18569d

GitHub Post by VitorBritto to properly uninstall MySQL

A comment on that post to properly uninstall MySQL on Apple Silicon devices

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.