3

I'm working to install Mongo on an arm64 machine with no success. Any ideas on what I'm missing? I'm following the steps defined at: https://www.mongodb.com/docs/upcoming/tutorial/install-mongodb-enterprise-on-ubuntu/

The error I see and the steps I followed are below. Any suggestions are appreciated.

root@bamboo8:~# systemctl status mongod
* mongod.service - MongoDB Database Server
     Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
     Active: failed (Result: signal) since Tue 2022-08-30 17:43:28 EDT; 5s ago
       Docs: https://docs.mongodb.org/manual
    Process: 2946 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=killed, signal=ILL)
   Main PID: 2946 (code=killed, signal=ILL)
 
Aug 30 17:43:28 bamboo8 systemd[1]: Started MongoDB Database Server.
Aug 30 17:43:28 bamboo8 systemd[1]: mongod.service: Main process exited, code=killed, status=4/ILL
Aug 30 17:43:28 bamboo8 systemd[1]: mongod.service: Failed with result 'signal'.

The steps I executed to get here were:

wget -qO - https://www.mongodb.org/static/pgp/server-6.0.asc | sudo apt-key add –
 
echo "deb [ arch=amd64,arm64 ] http://repo.mongodb.com/apt/ubuntu focal/mongodb-enterprise/6.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
sudo apt-get update
sudo apt-get install -y mongodb-enterprise
sudo systemctl start mongod
sudo systemctl status mongod

As a final data point, when I try to execute mongod directly, I get this error:

$ /usr/bin/mongod --version
Illegal instruction
1
  • 1
    Sounds like you've installed wrong binaries (or your hardware is not compatible)
    – mustaccio
    Commented Aug 31, 2022 at 14:54

3 Answers 3

4

The ILL (Illegal Instruction) exception indicates you are trying to run binaries that aren't fully compatible with your CPU.

As of MongoDB 5.0+, the Minimum Microarchitecture requirement for official arm64 binaries is ARMv8.2-A or later. Some older or lower spec CPUs (like Raspberry Pi or Chromebooks) will not meet this requirement.

Workarounds are:

2
  • I've just installed Debian 11 Bullseye 64bit on my raspberry pi 3B. But on the page you provide for installing mongodb 4.4.x they only suggest Debian 10 ... Would it work anyways on Debian 11 ? I was trying to get the mongodb v6 without success ( Illegal instruction error ) :'(
    – Seba99
    Commented Feb 28, 2023 at 16:37
  • MongoDB mentions that Raspberry Pi's should use MongoDB 4.4
    – Marc
    Commented Nov 22, 2023 at 15:48
1

Some time past 4.4.10 the packages stopped being compatible with the arm64 that is in raspberry pis. Releases past 4.4.10 might work; i'm not sure at what point things stopped working.

In ubuntu focal or jammy, you can use the focal repo and install older versions of the packages:

deb https://repo.mongodb.org/apt/ubuntu focal/mongodb-org/4.4 multiverse

sudo apt-get install mongodb-org=4.4.10 mongodb-org-database-tools-extra=4.4.10 mongodb-org-mongos=4.4.10 mongodb-org-server=4.4.10 mongodb-org-shell=4.4.10 mongodb-org-tools=4.4.10
0

same issue there, neither v4.4 nor v6 official mongo works.

what I've tried so far installing non-official binaries

actually worked for me, but i still have my collection outdated and cant view or do anything with it on 6.0.7.

Running it on RPI-4 4gb Linux raspbpi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux

Could not find docker image to work with v8.0a architecture either.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jul 14, 2023 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.