0

I use "sudo dnf install mariadb" to install mariadb on fedora36 but it showed me this error:

" file /etc/my.cnf from install of MariaDB-common-10.9.2-1.fc36.x86_64 conflicts with file from package mariadb-connector-c-config-3.2.7-1.fc36.noarch "

what should i do to install mariadb on my system??

1 Answer 1

0

dnf has various options to handle situations with conflicting packages. See e.g. --allowerasing, --skip-broken and --nobest. Check out the dnf man page for a more explanation on each.

Have you consulted the Fedora documentation on installing MariaDB? (See Install from Fedora Main Repo).

In particular, make sure to read the section Installing MariaDB server from the Fedora Modular repository.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy