I have started my SQL Server 2008 sqlcst02\inst01 in Single User Mode by appending the ;-m to the end of the startup parameters for this instance in SQL Server Configuration Manager. I have stopped SQL Server Agent for the inst01 instance. My account is a member of the Domain Admin group and I have attempted to login using sqlcmd -S sqlcst02\inst01 and keep getting an error that the service is in Single User Mode and only one administrator can be logged in. I tried adding ;-m"sqlcmd" to the startup parameters to limit the connection to just sqlcmd but I get the same results. I have tried this logged in as my own account and logged in as the local administrator account. I have started the command prompt as myself and as administrator but I get the same results. I have tried connecting using ADMIN:sqlcst02\inst01 in SSMS. No luck.

I'm attempting to reset the sa password as none of this information was left for me by the previous admin. This is maddening. I've done this before on other machines with no issues.

  • 1
    Is your domain account (either explicitly or via a group) a member of the sysadmin server role on the SQL Server instance? Jan 9, 2013 at 17:12
  • I don't know. I know I am a member of the Domain Admin group and a SQL ADMINS group, and that the SQL ADMINS group is a member of the sysadmin role on all of the other servers. but I'm betting that's not the case on this machine.
    – Bill Healy
    Jan 9, 2013 at 18:58
  • are your SQL running on a cluster? in that cluster service has open connection to SQL before you. Another possibility you have a service or application that is establishing connection to SQL server as sysadmin before you as an admin are able to connect. Jan 9, 2013 at 22:01
  • There's nothing wrong with the connection, and nothing wrong with the login. If you get to the point of seeing the single user mode error, you have to figure out what else is connecting to the instance, and prevent it for at least as long as it takes for you to establish the connection yourself.
    – Jon Seigel
    Jan 9, 2013 at 22:47

4 Answers 4


Another alternative to recovering access to a SQL Server is outlined in this article, and doesn't require restarting in single user mode:


Essentially, download PSExec, then run it with the following command line (fill in your location of SSMS.exe):

PsExec -s -i "C:\Program Files (x86)\...\ssms.exe"

You will be prompted to connect - the authentication mode will be Windows auth and hard-coded to NT AUTHORITY\SYSTEM. Once connected, you will be able to go into security and fix the sa password, add yourself as admin, add other admins, etc.

The article above has several caveats you should read before trying this, and you may also want to review the comments at the bottom.


I just got bitten by this one. What I had forgotten was to run the CMD prompt as administrator. This is not the default in Windows 2008 R2. Once I did this all was well. One of my colleagues suggested this issue and hey presto all fixed. I feel like an idiot but I thought I would share to save others.


OK - if you are not in the sysadmin role on SQL Server, you will not be able to enter via single-user mode. If you are an administrator on the server itself, you can use the answer in this post to help you out.

  • If you are an administrator on the server itself you can login via single user mode as described in the docs and it will treat the connection as though you are in the sysadmin role. Which as far as I can see is exactly what the blog post that is linked to from your other link does. Jan 9, 2013 at 22:06

I had a similar issue, where I had a cluster go down because I set the maxmem to 12 (instead of 120000, my zero was broken apparently)

I noticed that when I used the normal startup parameters prompt and sqlcmd -A I was getting login time outs, and error messages telling me the DAC was likely not connected.

I started the sql services by copying the startup parameters from the configuration manager into an administrative powershell prompt, and added the -cf parameters.

In another window I was able to use sqlcmd, but not with the -A parameter, just standard connections.

At that point I was able to run queries and sp_configured my way out. This was with a domain account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.