Currently our server is on Microsoft SQL Server 2016 (SP3) (KB5003279) - 13.0.6300.2 (X64) Aug 7 2021 01:20:37 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows Server 2016 Standard 10.0 (Build 14393: ). This is secondary read-only AG replica. We installed SP3 on both Primary and Secondary replicas. However recently the 2ndary node states this in the Windows update

Updates are available: SQL Server 2016 Service Pack 2 (KB4052908)

If service packs are cumulative, why does the server says this. Any thoughts? Thanks.enter image description here

SP3 Installer


  • Do you have any other instances installed? Commented Sep 28, 2022 at 19:45
  • Only default instance. No other named instances. Confirmed it from config mgr and services.msc
    – Kris
    Commented Sep 28, 2022 at 22:01

1 Answer 1


This can happen if you install a component on the same instance, after the instance has been patched. You have an unpatched RTM component (for example: full text search) and SP3 database engine.

If you were running SP3, and recently added a new component (Replication? Full text search? SSRS?) then only those components need patching. You can open the SP3 installer GUI, and step through it to see exactly what component(s) need upgrading. You can then cancel out on the installer without installing.

EDIT: based on the screenshot you uploaded, the "shared features" have been patched to SP3, but the service pack was not completely installed for the Database Engine & SSRS.

You can see the logs for every run of the installer, including incomplete installs. The detailed logs and summary output are located at %programfiles%\Microsoft SQL Server\nnn\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\. These can be a lot of data to go through, but if you can identify the SP3 install logs from the previous install, that might help explain why the SP was incompletely installed.

  • Thanks Andy, I ran SP3 installation and it says this (see uploaded image). Will try to install during next month production reboot window. Will update here. Thanks again.
    – Kris
    Commented Sep 29, 2022 at 14:10
  • @Kris That's exactly what I expected. I added some more detail to my answer to help you troubleshoot what might have happened with the incomplete install.
    – AMtwo
    Commented Sep 29, 2022 at 14:20
  • 1
    Thanks Andy. It worked. Looks like SSRS component was the issue, applied SP3 and issue fixed.
    – Kris
    Commented Oct 17, 2022 at 1:39
  • Looks like it popped up again, It says no instances or features that can be updated. Still windows updates says, Failed to install SP2. Thanks.
    – Kris
    Commented Nov 21, 2022 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.