I'm trying to use DBeaver to manipulate an SQLite database and, pretty much any operation I try on the database schema, like creating a table or column, it fails with:

SQL Error [1]: [SQLITE_ERROR] SQL error or missing database (near ")": syntax error)
  [SQLITE_ERROR] SQL error or missing database (near ")": syntax error)

Do you have any idea on how to fix it?

enter image description here

  • Assuming you haven't solved it, yet: it would help if you would provide more information on what you are actually doing? What is the simplest example you have that fails? In most cases these errors are related to syntax errors in your SQL statement. And if you have solved it: what was the problem and the solution? I would advise to read: ask questions
    – Ray Oei
    Mar 28 at 13:23

1 Answer 1


This can happen when you have more than one Database Connection.

You need to go to the database "SQL Editor" > "Set active connection"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.