1

I would like to use these two pages to enable DSE Unified Authentication and realize a secure environment. I have tried to configure it but it does not work. How is it as a symptom. When I type nodetool -u -pw status I get

 "nodetool: Failed to connect to '127.0.0.1:7199' - FailedLoginException: 'Failed to login. Please re-try.'."

is returned.

  1. nodetool status command from node2, which has not touched any files related to DSE Unified Authentication from the initial state, confirms that node1 is working as usual.

Please let me know if you have any other suggestions on what else I should try or if I should change a file here or there. If I hit nodetool -h drain, etc. from another node, I get an error, but it is not an Error about Authentication, but a ConnectException.

DOCUMENTS https://docs.datastax.com/en/dse68-security/docs/Auth/secEnableDseAuthenticator.html https://docs.datastax.com/en/dse68-security/docs/secJmxAuth.html Enabling JMX Native Authentication. procedure is not implemented.

1
  • Sorry for the delay in responses -- the Cassandra community were in New Orleans last week for ApacheCon. I myself am flying home back to Australia today so we will get back to you with an answer as soon as we can. Thanks for being part of our community. Cheers! Oct 12, 2022 at 23:26

1 Answer 1

0

It isn't clear from your question what steps you've taken to enable JMX authentication. You didn't indicate whether you're using local authentication or external authentication with the DSE Authenticator.

In any case, the possible reasons for you not able to run nodetool commands are:

  • incorrect configuration
  • incorrect username and/or password

If you provide additional information about your configuration, particularly clear steps on how to replicate the problem, I'd be happy to review them again. Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.