I am working with Azure Synapse Serverless SQL Pool. A former employee created the databases in the pool, and is listed as their owner. Consequently, I cannot drop the login.

I would like to change the owner of the databases to [sa]; however, all the means I know to change database owners in TSQL do not work in Serverless SQL Pool.

For instance, sp_changedbowner does not exist. Also, ALTER AUTHORIZATION is not supported. I've tried syntax that works in other non-MS databases, such as ALTER DATABASE x OWNER TO y, but this is not valid TSQL.

What is the proper way to change a database owner so it's not tied to a long-gone employee?

  • Have you tried sp_changedbowner?
    – MBuschi
    Oct 6, 2022 at 7:04
  • Yep. As mentioned (but misspelled) in my question, that does not exist in Synapse Serverless SQL Pool. Oct 6, 2022 at 15:07


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.