1

I see from the docs that I need to use parameter groups instead of a configuration file. The doc on parameter groups says that max_wal_size is available in parameter groups.

However, when I go to a parameter group (either the default ones or custom ones that I create), I don't see max_wal_size as a parameter.

DB Cluster Parameter Group

DB Cluster Parameter Group

Parameter Group

Parameter Group

How do I get access to max_wal_size? Also, what's the difference between a Cluster Parameter Group and a Parameter Group (which has lesser number of options, by the looks of it)?

1 Answer 1

2

What's your use-case for wanting to modify the max_wal_size parameter?

Aurora Postgres doesn't write traditional WAL records due to the proprietary Aurora storage that Aurora is built on.

A cluster parameter group is used for parameters which apply across all instances in your Aurora cluster.

A DB instance parameter group allows you to assign parameters to individual DB instances where you may require a different configuration based on your workload.

The max_wal_size is not customizable in Aurora Postgres, the docs you reference are for RDS PostgreSQL. https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/AuroraPostgreSQL.Reference.ParameterGroups.html

Also, it's never possible to modify the parameter in the default cluster OR default DB instance parameter groups. You need to create a custom parameter group for the version you're using modify the custom parameter group and then assign the custom parameter group to the cluster or DB instance. You will need to reboot to assign the custom parameter group.

https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/USER_WorkingWithParamGroups.html

HTH.

1
  • Thank you! I was confused between Aurora and RDS. In the CDK code, it turns out the construct may be rds.DatabaseCluster but the engine is still rds.DatabaseClusterEngine.auroraPostgres.
    – Chaos
    Nov 10, 2022 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.