0

I installed Oracle Linux 21c on the remote machine, tested it in Linux shell, and it worked as expected (I can query the testing table I created). But I am stuck when trying to connect to the database from local SQL Developer client (Version 22.2.1.234).

I downloaded 3 ODBC-related packages

  • instantclient-basic-windows.x64-21.7.0.0.0dbru.zip
  • instantclient-sdk-windows.x64-21.7.0.0.0dbru.zip
  • instantclient-odbc-windows.x64-21.7.0.0.0dbru.zip.

Above were unzipped and put in C:\oracle\instantclient_21_7. I also set up the DSN following https://windowsreport.com/install-oracle-odbc-driver-windows-10/.

On my laptop (Windows 10), I found ORACLE_HOME location and then created the TNSNAMES.ORA file following https://www.databasestar.com/tnsnames-ora-file/.

I launched SQL Developer, but the Database Connection panel showed:

No TNS entries found in {USER Home dir=C:\Users\xxxx, TNS_ADMIN=C:\oracle\instantclient_21_7, ORACLE_HOME=C:\Users\xxxx\AppData\Local\Temp\Temp2_WINDOWS.X64_193000_db_home.zip\network\admin}.

I tried to ignore above warning and created an Oracle Connection (Connection Type = TNS; Network Alias = net_service_name), clicked Test button, and I got an error:

Status: Failed: IO Error: The Network Adaptor could not establish the connection…

I couldn’t figure out what went wrong. Can anyone help please? Thanks in advance.

3
  • 1
    I don't think C:\Users\xxxx\AppData\Local\Temp\Temp2_WINDOWS.X64_193000_db_home.zip\network\admin is a valid folder for ORACLE_HOME Commented Nov 28, 2022 at 13:50
  • 1
    Where did you create the tnsnames.ora file? The folder you must put into TNS_ADMIN variable. Commented Nov 28, 2022 at 13:51
  • I opened the registry editor, selected ORACLE - KEY_OraDB19Home1, double clicked ORACLE_HOME reg_sz, and saw Value data = C:\Users\xxxx\AppData\Local\Temp\Temp2_WINDOWS.X64_193000_db_home.zip. This makes me think the path is where my ORACLE_HOME is located at... No? Or perhaps I should copy that .ora file to C:\oracle\instantclient_21_7 @WernfriedDomscheit?
    – geopark
    Commented Nov 28, 2022 at 21:49

1 Answer 1

0

Okay, I figured that out. sysdba is not a username, and I entered it when testing the connection. Certainly it wouldn't work. So, I created a user and used its username and password to connect to the remote DB and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.