1

I have a problem with the export via EXPDP for Oracle12 databases.

When the export is local, no problem. When I use an NFS share, the export starts, creates the log file, then nothing.

VM where the database is located: Oracle Linux Server - 6.10

Database version: Database Jan 2022 Release Update : 12.2.0.1.220118

VM where the NFS share is located: CentOS 7


Export NFS:

/MY/PATH IP_DB_VM(rw,no_root_squash,sync)

FSTAB:

IP_NFS_VM:/MY/PATH /NFS_MOUNT_PATH nfs   rw,bg,hard,rsize=32768,wsize=32768,nfsvers=4,nointr,timeo=600,actimeo=0,tcp,nolock        0 0

I manage to mount the share, to write on it with the user oracle. But when I run the expdp utility, it hangs.

My expdp command:

expdp MY_USER@MY_DB full=y directory=MY_NFS_SHARE_DIRECTORY dumpfile=expdp_MYDB.dmp logfile=expdp_MYDB.log

The export appears in DEFINING when I look at its state in the database, and I am then forced to kill the process (the KILL_JOB does not work)

If you have any idea what might be causing this behavior, and how to fix it!

Thanks in advance!

1 Answer 1

0

I managed to make the NFS mount work by changing the mount option nfsvers=4 to vers=4. I also deleted all jobs in NOT RUNNING and DEFINING state in case it could impact the other export/import jobs.

What remains unclear is that another NFS mount with the same configuration, and using the vers=4 option, still does not work.. I'll edit this answer if I find the cause for this 2nd problem

EDIT → I updated nfs packages on the other NFS VM, and reboot it. The expdp works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.